No display, no beep.. but fan, keyboard and lights are on

Hi!
(Sorry for my bad English it's not my first language)

So I'm completely new in PC building and I decided to invest and build my own.. I'm a complete beginner and I don't understand everything yet.. I assembled everything together .. But I don't have any beep sound , no display... My led fan are running.. my keyboard and mouse works.. my cpu fan and my graphics card fans are running.. I see light on my motherboard... So I basically tried everything ... I don't think it's the RAM I tried removing them and placing them in different spots , tried them one by one too... I don't think it's the graphics card too.. I checked the cables.. the SSD drive too ... I honestly tried to do so much things and I watched every YouTube video possible..my only conclusion is that the motherboard is dead... I don't know if I broke it somehow ??


I'm sorry I'm a complete noob and I honestly don't know what to do.. so if someone could help me and teach me I would truly appreciate it😣☀
 

Exabyte

Posts: 21   +1
I’m no PC Expert but try taking out the CMOS Battery, wait for about 5 minutes, and place it back in again.

It’s that little button on the Motherboard but I am sure you know what I mean
 
  • Thread Starter Thread Starter
  • #3
I’m no PC Expert but try taking out the CMOS Battery, wait for about 5 minutes, and place it back in again.

It’s that little button on the Motherboard but I am sure you know what I mean
Yep I did and it didn't work 🤷🏻‍♀️
Turns out my motherboard was dead I changed it and now everything works perfectly :))