NTLDR is missing, nothing I've tried works

By jmar20055 ยท 14 replies
Oct 9, 2008
  1. Hi there,

    Recently my computer stopped booting past the windows xp load screen. I decided to do a fresh, clean install of windows xp to clean it up as i was experiencing virus problems. I couldnt find my system recovery cd from the manufacturer so i borrowed a friends XP cd that was also windows xp home addition, same as mine. During the install i set two partitions on my hard drive so that I may install a Linux OS when time allowed.
    During the install i kept recieving messages that a certain file was unable to install, i could retry or skip. I retried the first one and it was successfull. On another file ii wouldn't install, so i decided to cancel and clean the disk. When i put the disk back in i got the dreaded NTLDR is missing, press ctrl alt del to restart. From what i read the windows disc is a bootable disc. it should boot from the CD.
    So i went into my BIOS and ensured the boot sequence was set to the cd/dvd drive first. i disabled the floppy boot since i decided not to have a floppy drive installed on my computer.(dumb idea i now realize) My computer should now only be attempting to boot from the cd drive, and then the hard drive. I still got the same response. "NTLDR is missing, press...."
    Next i disabled the hard drive. No help. I've tried creating a bootable disk with the NTLDR files. I've tried everyting from computerhope/issues/ch000465. I've tried everything from tinyempire/notes/ntldrismissing which is were i tried the boot disk option. I am pretty confident that the hard drive is set up correctly in the bios.
    One thing in particular that i fear is that when repartitioning the hard drive before the new install i didnt handle it properly. i created a bootable superfdisk to try to repartition the hard drive but i recieved the same"NTLDR is missing" message.
    Oh, to add to the problem, after the motherboard logo screen i recieve a Fasttrack PDC42819 message, "No array is defined, pres ctrl f to enter fastbuild utility." When i enter fastbuild it gives me 4 options.
    1. View drive assignments
    2. Define LD
    3. Delete LD
    4. Controler configuration

    Only number 4 works. Once i enter number 4 i have no ability to conigure anything. The top of the screen says "No parameters defined for currnet disks"

    I turnd the RAID controler off in my BIOS and that took the message away, but i doubt it solved the problem.

    In all my research i have found no help for that problem.

    Today i went to FRYs to get a linux OS and rid myself of windows altogether. I was told linux is online available only. Would booting from a Linux, prob. GNOME, os install disk actually install or would i recieve the NTLDR is missing message again?

    I have since found my recovery disk and guess what, "NTLDR is missing, press ctrl alt del to restart!!!!!!!"

    Im running an MSI k9a2 platinum motherboard, amd phenom 9600 quad-core processor. 230gb western digital hd. 3gb ram.
    IDE primary master- ATAPI CDROM
    Slave not detected
    Sata1-Hard disk

    Any help would be super, and ideas would be great, any questions will be answered by me asap. Thanks.
  2. pcaceit

    pcaceit TS Rookie Posts: 315

    Very strange!

    I would have said that your cd was damaged or Burned with incorrect boot sector settings, but as your original recovery cd gives same result it is strange.

    Does this happen immediately after you press the any key to boot from cd..... at startup? or does get to any other screens first?
  3. jmar20055

    jmar20055 TS Rookie Topic Starter

    no opportunity

    there is no option to boot from disk. I've seen the Press any key to boot from disk when i initially started the fresh install of the windows xp disc, there was the press any key message. But since then i have recieved no option to "press any key to boot from disc." it goes straight from the MSI motherboard logo screen giving me the bios chance, then goes into the fasttrack(fastbuild) screen, then a completely black screen with a flashing "_". this lasts anywere from 3 to 15 seconds and i hear the cd rom kicking in. imediatly following the "_" screen is the NTLDR is missing screen. every time... i dont want to take my computer in, i dont want to. but i have not seen any scenario online that compares to my problem.
  4. tuant

    tuant TS Booster Posts: 202

    Have you tried to reset the CMOS?
  5. pcaceit

    pcaceit TS Rookie Posts: 315

    OK! I think we might just be able solve this one

    Your Bios is not attempting to boot from your cd, it is bypassing the cd boot and attempting to read your currupted install on your hdd. I believe it is your Bios settings that is the problem.

    Your messages you received when you first attempted to install indicates a damaged cd or hdd errors.

    I would suggest that you clear your cmos for the moment.

    I will look up your mB details and get back to you with configuration settings for your bios.
  6. jmar20055

    jmar20055 TS Rookie Topic Starter

    I have not even considered that. is there specific reason i'd do that? Time and Date settings? I'm about willing to try anything. Does replacing it consist of a manual hardware replacement or is there something through BIOS i can do?
  7. tuant

    tuant TS Booster Posts: 202

    To revert back to factory settings.....
    Depending on motherboard type, its just simply switching the jumpers back and forth. Sometimes theres even a little 'reset' button on the board itself. Refer to your motherboard manual for reference on how to clear cmos.

    Attached Files:

  8. pcaceit

    pcaceit TS Rookie Posts: 315

    Just looked up your MB manual

    After you have reset the CMOS
    set time and date and check to see if boot devices are set in the correct order, The Default settings for the rest seems ok so you dont have to change anything else.

    When you start xp setup again delete all the partions on the Hard drive, just create and format the partition you want xp on (create the rest when xp is installed) if you plan to use linux you will need to leave free unpartitioned space.

    If you get those unable to install/read/write files during install then it means your cd is damaged or corrupted.

    keep us updated
  9. jmar20055

    jmar20055 TS Rookie Topic Starter

    seriously, you guys are amazing! I'll get back to you as soon as i have the chance! Thanks a ton!
  10. jmar20055

    jmar20055 TS Rookie Topic Starter

    just cleared the CMOS. made sure the boot sequence in the bios was correct. i restarted with the recovery disk in and got the same message. NTLDR is missing. restarted with the XP disk in and got the same message. NTLDR is missing. would my OEM really not include that/those files on the recovery disk?
  11. tuant

    tuant TS Booster Posts: 202

    You check to see if your cd-rom is functional? This is very strange....... If you have a USB cd-rom, try booting the disc from there and see what happens.
  12. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    Restart, get into your bios and force the bios to look at the attached devices again. It seems certain your CD reader is not being recognised, or if it is, it is no longer functioning. The bios should actually identify the make and model of the CD. If it just says 'auto' that may not be enough.

    I would definitely concentrate all efforts on finding out why the CD is not working. Recheck cable connections, does the drive light come on at boot time, does it spin up, can you substitue another drive temporarily, and another cable.

    If all this fails to correct the problem, I would suspect a boot rom failure or (very remote possibility) a virus. Either way I would download and flash the latest boot ROM for the motherboard, but then I have a working floppy disc to do it from ! Without even a working CD you would need to do that from a bootable USB stick or similar. See what the motherboard manual says about reflashing the bios.

    Oh, and another thing. Once the CD issue is solved, enable the floppy boot and you can do many things - like run dear old DOS fdisk and make the hard drive abosolutely empty of any partitions before you start. Failed OS installations can leave the hard Drive in any odd state, well able to confuse a bios....
  13. BillAllen55

    BillAllen55 TS Maniac Posts: 368

  14. pcaceit

    pcaceit TS Rookie Posts: 315

    If there is no "press any key to boot from cd/dvd" message after post, and cd/dvd is set as first boot device in bios Then problem is with the drive, if your bios is not showing the id of the cd/dvd drive in setup then it is not connected or failed, at worse the ide controller on the mb is failing, the the pins or cable is dammaged.

    You have to try a different cd/dvd drive to diagnose the problem.
  15. jmar20055

    jmar20055 TS Rookie Topic Starter

    Yup yup. Installed an old cd drive, booted from disk nice and clean! Everything works like a charm. It does anger me some that a brand new cd/dvd drive would flake out like that, but then again it is an electronic device and that does happen. Just want to say thanks to all those who helped out with this one. It is very nice to see others who genuinely want to help. I'll be coming back here for all my computing problems!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...