Old image of XP home will not fully boot

By gbhall ยท 11 replies
Mar 2, 2009
  1. My PC came with OEM XP-home on partition 2 (follows a hidden install in partition 1). After a couple of years, I aquired XP-pro and created a new partiton 4 at the end of the drive and installed it there. Works just fine. After everything proved out, I thought to move partition 4 down to the original space of XP-home, and use partition 4 for Linux, so I took Acronis true-images of partitions 2 and 4, restored 4 into 2 and changed boot.ini to tell XP-pro it was now in partition 2. This worked fine also.

    So I had partitons (1) hidden (2) XP-pro 2 (3) data (extended)

    Just before installing Linux in 4 I felt a need to put the original XP-home (from 2) in primary partition 4 in order to check some program settings. Did the same image restore as when moving (4) to (2), changed boot.ini as approriate, but surprisingly, although XP-home boot starts, and gets to the point where i have dark-blue top and bottom light blue in the center and the XP logo, the next thing which should be immediately adding the words 'Windows is starting up' does not happen. Everything just stops at that point.

    Have I overlooked some other startup setting I should have done apart from boot.ini, or is this peculiar to the OEM install which expects to find itself on partition 2 ?.... or any other suggestions please ?
  2. Sharam

    Sharam TS Rookie Posts: 509

    Since the information in the MBR and paths has changed few times and perhaps not correctly in the last attempt, there could be few possibilities.

    Does Safe Mode work? IF it does, do you get error for swap file too small or corrupt (something to that tune)?

    Double check steps you took after the image was restored to partition 2.

    Is the hidden partition a Recovery partition from an OEM?

    Since you have all needed images, is it feasible to delete all partitions except the hidden one and restore the original second partition from the image? Any data in the data partition?
  3. gbhall

    gbhall TechSpot Chancellor Topic Starter Posts: 2,431   +77

    Good suggestions Sharam. I have written the MBR a few dozen times because I am using Gag Booter to control the starting partitions. The boot.ini must be ok as the boot procedure gets almost all through.

    Safe mode with command prompt I just tried. It stopped at agp440.sys for a long time, then went to the standard safe mode screen, then instead of giving me a command prompt, appeared to try to continue a full boot, stopping at the same place.

    The hidden partition is a recovery partition, I dont want to reinstall and all that several times over just to check a few points, this is not panic stations, but I will try...

    (a) safe mode without command prompt
    (b) delete the page file (come to think, the page file might actually be not on C:, but on another partition, and therefore used by XP-pro first. I bet that's it.)
  4. Sharam

    Sharam TS Rookie Posts: 509

    There are few cures for no page file, that might be it as well as paths in the registry, there is a tool I think which allows you to view and edit the Registry on another hard drive.

    My clones and restore issues had to do with page file all the time, for me removing partitions and adjusting the MBR before the clone or restore job, works all the time!

    Interested to know how you make out.

    EDIT: have a read here, just did a quick search
  5. mflynn

    mflynn TS Rookie Posts: 2,655

    If you can boot the other OS XP Pro then browse to the XP home drive and delete any pagefile or hyberfil.sys

    Then browse to the \Windows\Temp and delete all in it.

    I would also Chkdsk the XP Home drive.

    But by your description of the attempt at Safe Mode appear to be having a Video or other driver problem.

    I would unplug any external devices like printers and flash drives.

    You may need to do a repair install.

  6. Sharam

    Sharam TS Rookie Posts: 509

    Hi mflynn, good call.
  7. gbhall

    gbhall TechSpot Chancellor Topic Starter Posts: 2,431   +77

    I am up for the challenge on this one. Your fascinating link, Sharam, to agp440.sys problems, has raised another set of possibilities, the most prominent of which is USB drive assignments.

    What I have eliminated so far is:
    Not a drive read problem (chkdsk /f no probs, partition magic no probs)
    Not a pagefile.sys problem (moved xp-pro pagefile, deleted all pagefiles, saw xp-home create a new one while booting)
    Not a video/agp problem (started safe mode vga, which started and stuck in exactly the same place)
    I have yet to test removing as many peripherals as possible,

    Here is an interesting scenario... XP-home, when still in partition 2, saw new install of XP-pro in partition 4 as a primary drive, letter F: (I never bothered to hide it from XP-home)
    So now that XP-home is in partition 4, it is trying to boot (as C: ) off a partition it previously knew as a seperate partition with a letter F:. Kind of recursive......how would you get round that? Without a repair install that is, because I only have a restore partition and an XP-pro install CD
  8. Sharam

    Sharam TS Rookie Posts: 509

    The only thing I don't see you mention of is chkdsk as suggested in the Link and by mflynn, let me check on this, I never had this exact situation and have to rely on my experience and knowledge which is limited in this area and I'm not MS certified by any means but Novell :).

    You apparently have more experience with this, I have a good understanding of the whole concept, and do appreciate new challenges other than the usual daily hardware, software and infection scenarios!
  9. gbhall

    gbhall TechSpot Chancellor Topic Starter Posts: 2,431   +77

    Check post #7, not only did chkdsk pass, with full read check as well, and so did partition magic which can also do a similar check.

    Oddly, partition Magic did cough a little, first saying the partition was not at the place or size expected, or something, but seemed to fix that without asking a by-your-leave. What that could have been was that xp-home was originally 20Gb in size, and TrueImage restored it to a 10Gb partition, although only 8Gb was used, and TrueImage did not bat an eye...

    Since post#7 I have booted with all USB and network connections off. Still no change. I next will do a logged boot when I have time.
  10. Sharam

    Sharam TS Rookie Posts: 509

    Thanks for the update.

    I guess I should set an appointment with my "eye doctor" never saw that :)
  11. gbhall

    gbhall TechSpot Chancellor Topic Starter Posts: 2,431   +77

    This may have a bearing - from MS knowlegebase Q249321 "This problem can occur if your Windows 2000 boot partition drive letter does not match the drive letter assigned during the initial Windows 2000 Setup. Windows 2000 maintains a record of drive letters in a registry based database and re-assigns drive letters based on Globally Unique Identifiers (GUID) recorded for each volume. Should the volume GUID change or be duplicated (by hard drive cloning software), the original drive letter may not be re-assigned to the boot volume."

    One solution is to re-write the MBR. I am going to try that.

    The KB refers to Win2K but nothing changed for XP as far as I know. The volume GUID is the same, I would think, in my case, but who knows? The original problem of this KB article is a question about "boots as far as starting user login, but login not allowed". Not too different from my problem.

    Update : have now booted after a new MBR - no change. I booted with logging, and the content of ntbtlog.txt is attached. Obviously, I have no way of knowing if that is complete, because after the PC seizes up, I have to restart with a switch reset,
  12. Sharam

    Sharam TS Rookie Posts: 509

    Where are you with this gbhall?

    My business has picked up again after being dead for all Jan and most of Feb, I go 48 hours with no rest at times :) and have not been able to be here as much.

    Hope it worked out for you.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...