Spread the love! TechSpot Tech Gift Shortlist 2017


By mbrogden ยท 8 replies
Oct 8, 2008
  1. Hi

    I have just put a rig together with some old parts of mine,

    I get the PAGE_FAULT_IN_NONPAGED_AREA upon boot up.

    The HDD i am using has XP on it.

    I have now wiped the HDD and i still get the BSoD when i am trying to re-install XP

    Please Help
  2. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    As per auhma.org:


    Requested data was not in memory. An invalid system memory address was referenced. Defective memory (including main memory, L2 RAM cache, video RAM) or incompatible software (including remote control and antivirus software) might cause this Stop message, as may other hardware problems (e.g., incorrect SCSI termination or a flawed PCI card).

    * Test RAM and harddrive.
  3. Southern Belle

    Southern Belle TS Rookie

    I too am getting this message on my cousins computer but can't get anywhere but the blue screen on start up then it says that c:\\windows\system32\config\system is not found and then reboots to same thing, i have tried to recover and reinstall with no luck. I can't get past the error codes :: PAGE_FAULT_IN_NONPAGED_AREA, STOP: 0x00000050
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Read my previous post. Test the RAM and let us know the results. I had bad memory that caused my system to reboot.

  5. Southern Belle

    Southern Belle TS Rookie

    re: memory


    well i opened it up changed memory banks and used them 1 at a time with and same thing with the error i can't get anywhere just the setup but fails. i did notice that when finally getting to dos that doing a "dir/p" gives nothing but the commands and doesn't list any directories.

    i ran memtest and everything passed. sense its not the memory oh and i couldn't disable the L2 cache in bios either, im thinking that maybe it is the hard drive she is going to get a new one and will try to do the setup on that one.

    when trying to do setup it get to the press r for recovery or enter to setup windows and either of them by passes the error so no windows at all

    any other suggestions is greatly appreciated.
  6. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Have you run a full harddrive diagnostics as well as chkdsk scan? I know she is getting a new one but it would be interesting to see if that is where the issue lies.

    Also, have you scanned for possible infections?

    Lastly, how long did you run memtest?
  7. Southern Belle

    Southern Belle TS Rookie

    Re: error


    i cant scan anything cant get to anything. memtest ran for about an hour. I did test on the hard drive the night before and got a fatal error of tnt.10049 out of stock buffers then it was something like command not found and was frozen. i got to dos but u cant run setup from dos but when i looked at directories there were none on drive C

    thanks for your reply

  8. Route44

    Route44 TechSpot Ambassador Posts: 11,979   +71

    Memtest needs to run a minimum of 7 Passes. If you got a harddrive disk error than it sounds like a new HD is certainly needed as you indicated in an earlier post.
  9. Southern Belle

    Southern Belle TS Rookie


    thank you for responding i think your right it sounds like the hard drive since her memory is ok and i swapped them or interchanged them and added them one by one and all seemed fine. but the hard drive seems to be the only answer as you said. thanks again i'll post when she gets the new hard drive.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...