PC restarting when i play a high quality game

By Ayzake
Jun 18, 2013
Post New Reply

  1. I have the following SPECS:
    CPU: i5-3570k @non-overclocked
    GPU: GTX 670 FTW 2GB @non-overclocked
    MEM: 8GB G.Skill 1600Mhz
    PSU: Aerocool Strike X 600W

    Here you can see my HWMONITOR:

    Here you can see my hijackthis:


    I have try everything, change the GPU PCI slot, cleaning all PC, and so much ways, some ideias to me try?
    Sorry my english, im brazilian...
  2. gracebie

    gracebie TS Rookie

    First I will suggest you to upgrade your graphic card to play high quality games
    - Or there may be your graphic drivers are out of date so I will suggest you to restart your computer and then press and hold F8 keys until you get Advanced Options menu screen.Use the arrow key to highlight Safe Mode, and then press Enter, your computer will boot automatically to safe mode.
    - After that go the site of your system manufacture. Once there enter the model number of the system then request driver (usually found in the web site's "Support Section"). There you should be able to find all the drivers for your model
    hopefully you will get better results
  3. Ayzake

    Ayzake TS Rookie Topic Starter

    I was in uptodate driver, 320.18, this give me some artifacts in BF3, I think I didnt unistalled completly because I'm getting artifacts in BF3 with 314.22 version, I don't know what I do!
  4. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +242

    Re install the latest update from Geforce.But when doing it.Click the box that says clean install. This may help you with your problem

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...