Pen drive: copy problem in Windows 7


Posts: 72   +5
I'm using 2 pen drives. Kingston-4GB and Transcend 2GB. Transcend works fine on both my PC and Notebook. But in my PC, Kingston didn't work properly while copying files to it.

When I insert the Kingston, it is detected, no problem when copying/moving files from it to my PC(speed was 14-15 MB/sec) and nothing happens when it is left on the port for hours.

But when copying files from PC to Kingston, it was slow, nearly 2-3 MB/sec(normally it'll be 4-8 MB/sec and increasing) and halts at some point and after some time, a dialog box(see attached pics). And in my computer, see the attached pic.




In my laptop, when copying the speed was slow(2-3 MB/sec)than normal, but the copy was successful.

I've formatted the Kingston both Quick and Full. And tried uninstalling the drivers of the USB ports and the Kingston pendrive 2.0 driver and reinstalled by refreshing. Still the problem persists.

If you're not able to see the images, here are the direct links to the images:


Posts: 142   +1
I've had a similar issue before with a USB flash drive. The issue only occurred for me when reading data off it, but not when placing data on it. It almost seemed like it 'lost connection' with the computer somewhere along the way.

What worked for me was to try a different USB port. The one I had it in didn't seem to like the USB drive very much, and it worked in all other ports.

If that doesn't work for you, it sounds like part, if not most, of the flash drive is corrupted/gone bad. From what you said about the slower-than-normal speeds and the failing to write to it (in some cases), it appears a section might be partly broken. The only solution would be to get a new flash drive (or return this one, but for anything <16GB that's more often than not a waste of money). Before you do that though, test it in some other USB ports, and preferably on other machines than your desk- and laptop. If it continues to preform poorly, it's broken.