Possible to reset login info on used DLink 108G router?

By macx
Apr 14, 2008
  1. XP Pro, latest version Firefox.

    Bought a used DLink 108G MIMO router, DI-634M, came with

    Started install process from CD, said it's installed.

    Then went to setup security, Username req'd.
    Directions say to use "admin" but it tells me it's invalid.
    Also gives an http address to type into the browser address bar,
    but the computer can't find that address.

    For adding a computer to the local network, it says there should
    be an icon in the system tray to click to proceed, which there isn't,
    so can't add either my laptop or my desktop to the in-house network.
    That may be because the Security isn't set up? The installer does say
    the internet connection and the router are set up properly and

    Being used, the http address, Username & Password most likely
    have been changed after the initial setup?

    Have inquired with seller asking for that info, but have my doubts
    (believe it to be a re-seller of used items).

    Is it possible to gain access by resetting or finding out the current
    http, username & password somehow, or can the mfg do anything
    about that? For the http address, FF is set up to auto detect.

    Appreciate any leads - hate to go thru the hassle of a claim
    and then buying another & waiting for delivery. No internet in
    the meantime except for a little time I can sneak at work.

    Thanks for any help!
  2. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    Look on the back of the DI-634M, you should see a "reset" button. You might need a paper clip or a pen to push it in, but, hold in in for 10-15 seconds and it should set it to the factory default settings.

    The default IP address for the DI-634M is, use "admin" as the login name and leave the password blank.
  3. macx

    macx TS Evangelist Topic Starter Posts: 718

    Well, hallelujah!

    I was using that default address and admin and leaving the PW blank,
    b ut that's when it was telling me that everything was invalid (as U know,
    that of course is the install instructions on the Installer).

    Anyway, pushed that reset button for 20 secs, then it worked!

    I didn't think, being that info is directly tied with the security,
    that it would reset those items, of course never tried it :-/

    Easy when you know how!

    Now I know how!


    I still don't get the D link icon in the startup / system tray (whatever it's called). So no D link config utility. I checked in msconfig and there are
    2 D Link Utilities listed and checked for startup - ?? Oh, well, at least
    it finally works.

    On the router install there's an "Add PC to the system" button which says
    to click that D Link startup icon that's supposed to be there to add a PC,
    but without the icon, can't proceed any further. Or is that ONLY for desktops (is that what they mean by "PC"?). When I get my desktop card,
    that may be the next challenge :)

    Thanks again!
  4. Matthew

    Matthew TechSpot Staff Posts: 5,332   +101

    You're plenty welcome, macx.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...