Random corruption on SSD

By orondf ยท 4 replies
Sep 13, 2016
Post New Reply
  1. Hello world! I am finally back because I found a problem which completely baffles me.

    I seem to be getting random corruption on my SSD (Samsung 850 EVO 250GB, latest firmware EMT02B6Q). It is subtle, but corruption is definitely happening intermittently.
    All other hardware is most likely stable:
    • I have not noticed any corruption on my HDD (connected to the same SATA3 controller) except for "free space marked as allocated" reported by chkdsk today
    • My CPU OC is stable - I tested it for hours with Prime95
    • My GPU OC is stable - Stress tested it a long time ago
    • My RAM OC is probably stable - I ran Memtest86+ 4.20 for over 6 hours with no errors
    • I have had absolutely no BSoDs for a long time now
    Some important info:
    • SATA controller is in RAID mode, but I have no RAIDs configured. I set it because I was considering creating one in the future and needed to make sure Windows would still boot. (Registry edits were required)
    • Since this problem is intermittent, a good solution to it needs a way of checking if the problem is solved. I'd rather fix this now instead of waiting a month for my data to be corrupted again. I'm not sure what to do about this.
    • CrystalDiskInfo reported no abnormalities of any kind.

    Problem history:
    • 2 months ago - Might not be relevant. I used an old version of "avastclear.exe" to remove Avast and then I installed Avira. A few days later I noticed that Task Scheduler was not working: "The selected task {0} no longer exists". This was caused by some registry entries with blank/corrupted ACLs - fixed successfully.
    • 1 month ago - Strange msi error when installing certain programs, windows backup fails with "access denied", windows update won't check for updates. Disk cleanup shows 41GB of temporary files - if these are cleaned up, Windows will not boot until a System Restore is performed! SFC fixed some errors but that didn't help. Chkdsk found no file system errors and I interrupted it during the check for bad sectors in free space. After that TeamSpeak did not function properly and Windows reported file system errors at C:\$Secure while using it. I ran chkdsk again and ALL of the problems mentioned were fixed! At this point I disabled Samsung RAPID.
    • Now - Task Scheduler is suddenly not working again: "The selected task {0} no longer exists" but this time the registry entries are OK. Windows backup lost its configuration and fails with "access denied". Also, the file "C:\Program Files\AMD\CNext\CNext\D3Dcompiler_47.dll" has been corrupted and its size is 0KB, and AMD settings shows an error about this which didn't happen last time I opened it a few days ago (I haven't updated since before then, even though a new version was released). SFC and chkdsk found no errors.
    Only other issue I've been having aside from the ones mentioned above is graphical glitches/corruption in Minecraft (heavily modded 1.7.10 with 32x resource pack). This issue does not occur for others on similar configurations.
  2. EndlessWaves

    EndlessWaves TS Booster Posts: 191   +45

    Corruption in game isn't usually caused by hard drive, although Minecraft's resource use is unusual. If that glitching happens consistently then that might be a good test.

    I would try putting your overclocks back to stock speeds one by one and testing minecraft in between. If the corruption goes away then I'd test it with the previous overclocked turned back on. If it's still gone with just that one component at stock speeds then that's your likely culprit.
  3. orondf

    orondf TS Booster Topic Starter Posts: 94

    Thanks, I'll try that when I get the chance. (Thursday or Friday)
    (Notes: The graphical glitches are infrequent, and have 2 distinctive forms. I already tested with the GPU at stock frequencies before to no avail. I'm confused as to how it is related to the other issues, but it is worth investigating)
  4. orondf

    orondf TS Booster Topic Starter Posts: 94

    Just tested with all clock speeds at default - I still get the graphical glitches.
  5. orondf

    orondf TS Booster Topic Starter Posts: 94

    Is it possible that this is caused by the Intel RST drivers? I had a lot of trouble installing them on 2 copies of Windows 7 even before I had an SSD (a few years ago). Installing these drivers always resulted in Windows being unable to boot, regardless of controller mode being AHCI or RAID. Right now I have the driver included with Windows (version from 2010!) because that was the only way I could get it to work with the controller in RAID mode.
    Could the old version be causing the corruption issues? Or could it be a controller issue? I have no problem with switching back to AHCI but it will take a bit of fiddling with the registry, and I still can't think of a way to test for whatever is causing the corruption.

    EDIT: I just realized that the driver being used is for ICH8R/ICH9R/ICH10R! If I am not mistaken the last chipset to use ICH10R was from 4-series - I am surprised that this driver ever worked at all! This probably explains why Samsung Magician is unable to detect the SATA interface correctly. I still have no way of installing Intel RST without freezing at the Windows logo...
    Last edited: Sep 19, 2016

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...