Sandisk cruzer won't launch firefox

By babyaj · 11 replies
Nov 22, 2008
  1. i have a sandisk cruzer micro 8gb flashdrive and it won't launch the firefox browser i installed on it. i click on the u3 icon>other programs>mozilla firefox for u3 and nothing happens. i checked the task manager and it doesn't show firefox.exe is even running. i've deleted it and reinstalled it but get the same results. i also have opera loaded and it works just fine - please help.
  2. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Please remove Firefox from your USB drive
    Then download and install again:

    You may also need to default any firewall or live protecting apps like Spybots S&D
    Or just uninstall them
    Test the Firefox portable again
    Then re-install your Firewall etc
  3. babyaj

    babyaj TS Rookie Topic Starter

    thanks timsland

    thanks, i'll give that a try...
  4. babyaj

    babyaj TS Rookie Topic Starter

    still didn't work

    thanks for the advise kimsland but it still doesnt work.

    i unistalled and reinstalled firefox my flashdrive and it's still doing the same thing - machine. i also downloaded it as part of a suite from and everything in the suite lauches except firefox - weird...
  5. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    And this part?
    It could be that it has been disabled even from Windows firewall

    Actually re-installing should have removed all these options... thinking...

    Does it work from your Desktop? (probably yes)
    Is the USB drive write protected? (probably not)
    Maybe un-install Firefox from your computer as well (add\remove programs) actually this one is good :)
  6. babyaj

    babyaj TS Rookie Topic Starter

    still no workie :-(

    thanks again kimsland. i'm not able to disable the firewall because i'm using my drive at work and the network adminstrator has to perform all security functions, i may be out of luck - however the same thing happens when i use my home computer. the funny thing is that i used to have a pny flash and firefox worked just fine off of it - it's only when i started using the cruzer that it stopped launching. could it be something on the drive itself??
  7. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Good point

    When I got my USB flash drive I straight away went to the home site and downloaded all the tools to remove the software and hidden partition on the drive
    Actually I used another tool as well, hang on I'll get it :) ....................

    Arr, I'll just quote the whole thing, I'm not editing it


    Warning: The tools in 2. and 3. (below) will format (ie remove all data from) your flash drive, but as a last resort it is worth it.

    Check for a tiny switch on the flash drive, some have this
    Confirm it is not in the Write protect position

    HP USB Disk Storage Format Utility

    This will format most USB flash drives
    It can be known to recover Flash drives that are un-responsive too.

    If that doesn't work try this one:

    Hard Disk Low Level Format Tool (USB Flash drive "format" that is ;) )

    The following entails editing the Registry
    If you are not comfortable in doing this, or inexperienced with the registry, then don't do it ! Incorrectly modifying the registry can hae drastic effects on your system.

    Start->Run-> Regedit
    Expand: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies
    (Note: if this key doesn't exist, then disregard this option, and close Regedit)
    Double click on the string ‘WriteProtect’ and change the ‘Value Data’ box to ‘0’
    Close Regedit, and Restart

    Please reply if any of these options helped you :)
  8. babyaj

    babyaj TS Rookie Topic Starter


    thanks kimsland, i'll give one of those a try and let you know...:)
  9. babyaj

    babyaj TS Rookie Topic Starter

    i finally got it fixed. i downloaded firefox to my flash, but had to change the name of the file in order for it to launch - my company has a block on mozilla firefox.exe - whodathunkit!! :) thanks for your help and insight...
  10. kimsland

    kimsland Ex-TechSpotter Posts: 14,523


    Although I thought you said it didn't work at home too :confused:

    Anyway, thanks for the update :grinthumb
  11. babyaj

    babyaj TS Rookie Topic Starter

    good point, i'll try it at home and let you know...thanks for all your help!!
  12. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    Quite alright :)
    Let me know if there's still anymore issues (as you said)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...