1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

SATA DVD drive problems

By burgy77 · 4 replies
Jun 16, 2008
  1. Ok I just built a new rig. Specs are as follows:

    CPU: Intel Core 2 Duo 8400 3Ghz (33C)
    HSF: Zalman CNPS-9700 LED
    RAM: 4GB G. Skill PC2-6400 DDR2-800
    MOBO: EVGA 780i 132-CK-NF78 (29C)
    VGA: BFG 6800GT OC
    HDD: Samsung 200GB & 500GB SATA
    AUD: Onboard Azalia HD 8.1
    PSU: Antec PowerTrio 650W
    CASE: Antec 900
    MON: Samsung 24" 1680x1050 2ms
    OS: Windows Vista Business SP1

    Currently, I am unable to get my new Samsung DVD drive (SH-S203N from Newegg) to work with this system. When I attach it to the motherboard. Windows loads and after that it goes into a BSOD. Here is the Windows problem report:


    Shut down unexpectedly

    6/16/2008 5:35 PM

    Not Reported

    Problem signature
    Problem Event Name: BlueScreen
    OS Version: 6.0.6001.
    Locale ID: 1033

    Files that help describe the problem (some files may no longer be available)

    Extra information about the problem
    BCCode: 1000000a
    BCP2: 00000002
    BCP3: 00000000
    BCP4: 83C589C4
    OS Version: 6_0_6001
    Service Pack: 1_0
    Product: 256_1

    Also, attached is the dump file for this error. I have the most current BIOS and video card drivers. I downloaded Windows debugging tools and still am unable to read the dump file. It says that the symbols are wrong. Even though I downloaded them as well.

    I have tried calling EVGA and they were extremely unhelpful. I am at my ends here about ready to throw the drive out the window on to the driveway and use the ugly old IDE drive that does not match my case. Thanks in advance for any help.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    RMA/ replace the drive
  3. Spyder_1386

    Spyder_1386 TS Booster Posts: 465

    hey burgy77

    I'm assuming that by saying once you connect the DVD drive, the computer gives you a BSOD and when its not plugged in, everything works ok?

    This said, is the Controller setting in your BIOS set to "RAID" ?? if so, try changing it to SATA and see if that works....

    Spyder_1386 :)
  4. burgy77

    burgy77 TS Rookie Topic Starter

    The reason I didnt RMA the drive in the first place was I figured I was just setting something wrong and didnt want to deal with sending it back. I guess I will pay for it in the long run since I can no longer return it and an RMA will get me the same drive again. Like I said the drive doesnt seem to be faulty.

    As for making sure RAID is off I did that, and double checked it today. I also tried turning all of the IDE options off as well but it made no difference. Was anyone able to pull up the dump file? If you did could you possible paste it back on here or link it in a readable form? I would really appreciate it since for some reason I am unable to read it with Windows debugging tools.

    You would be correct I have no problems when I do not have the drive hooked up.

    So I finally got into the .dmp file. Heres what it says:

    * *
    * Bugcheck Analysis *
    * *

    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high. This is usually
    caused by drivers using improper addresses.
    If a kernel debugger is available get the stack backtrace.
    Arg1: ffffffe0, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000000, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
    Arg4: 83c589c4, address which referenced memory

    Debugging Details:

    READ_ADDRESS: GetPointerFromAddress: unable to read from 83d436d8
    Unable to read MiSystemVaType memory at 83d242e0


    83c589c4 8b51e0 mov edx,dword ptr [ecx-20h]




    PROCESS_NAME: System

    LAST_CONTROL_TRANSFER: from 83c4ccc0 to 83c589c4

    80780cd0 83c4ccc0 83d0f9c8 83d0f9c0 00000000 nt!ExpScanGeneralLookasideList+0x22
    80780d7c 83dbf6ad 00000000 e7135dbd 00000000 nt!KeBalanceSetManager+0x110
    80780dc0 83ca6686 83c4cbb0 00000000 00000000 nt!PspSystemThreadStartup+0x9d
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


    83c589c4 8b51e0 mov edx,dword ptr [ecx-20h]


    SYMBOL_NAME: nt!ExpScanGeneralLookasideList+22

    FOLLOWUP_NAME: MachineOwner


    IMAGE_NAME: ntkrnlmp.exe


    FAILURE_BUCKET_ID: 0xA_nt!ExpScanGeneralLookasideList+22

    BUCKET_ID: 0xA_nt!ExpScanGeneralLookasideList+22

    Followup: MachineOwner

    0: kd> lmvm nt
    start end module name
    83c17000 83fc1000 nt (pdb symbols) c:\windows\symbols\exe\ntkrnlmp.pdb
    Loaded symbol image file: ntkrnlmp.exe
    Mapped memory image file: c:\cache\ntkrnlmp.exe\47918B0A3aa000\ntkrnlmp.exe
    Image path: ntkrnlmp.exe
    Image name: ntkrnlmp.exe
    Timestamp: Fri Jan 18 23:30:50 2008 (47918B0A)
    CheckSum: 0036A9CE
    ImageSize: 003AA000
    File version: 6.0.6001.18000
    Product version: 6.0.6001.18000
    File flags: 0 (Mask 3F)
    File OS: 40004 NT Win32
    File type: 1.0 App
    File date: 00000000.00000000
    Translations: 0409.04b0
    CompanyName: Microsoft Corporation
    ProductName: Microsoft® Windows® Operating System
    InternalName: ntkrnlmp.exe
    OriginalFilename: ntkrnlmp.exe
    ProductVersion: 6.0.6001.18000
    FileVersion: 6.0.6001.18000 (longhorn_rtm.080118-1840)
    FileDescription: NT Kernel & System
    LegalCopyright: © Microsoft Corporation. All rights reserved.

    Anyone have ideas on how to figure out what ntkrnlmp.exe is? I am assuming thats what is causing the error. Unless I am misreading this thing.
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,231   +234

    Minidump points to a general Windows instability... Replace the drive after you have tried another SAT cable or SATA port
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...