1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Slow Page Loading with Firefox

By captaincranky ยท 4 replies
May 21, 2014
Post New Reply
  1. I have an ancient eMachines T-5026. (Intel P-4 519 3.06Ghz single core Prescott)

    I'm running XP-SP2, fully updated with the exception of SP-3. (If I install SP=3, I lose the ability to do a repair install. My AV product is AVG Free.

    This thing's my go to erotica finder. (Trust me, I don't log in to my bank with it).

    Anyway, it seems terribly slow at loading pages, with the CPU at, or pushing, 100% usage. I can't load more than one page at a time, or I get a "problem server reset before page loaded", type error. Once the other page(s) have loaded, a simple reload page command, establishes the connection.

    Firkefox, (@ ver. 29.01), is the browser of choice, with "NoScript" installed.

    I just did a repair install of the OS, which is the only way I could get it to reload the internet driver, (Intel 100/ Pro). That doesn't seem to have helped.

    My question is, I want anybody's best opinion as to whether this level of performance is what I should expect as typical with this rig, or is it just plain worn out, and I should retire it with full military honors.:D:'(
    Last edited: May 21, 2014
  2. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,481   +975

    Try disabling no script. That may be eating up all your resources and slowing down the loading of webpages. If that doesnt work, try another browser like Chrome. I would try completely clean installing windows rather than repairing it since just repairing will not clear anything such as viruses off of the PC. Malware could be another culprit and clean installation will allow you to wipe it out.
  3. captaincranky

    captaincranky TechSpot Addict Topic Starter Posts: 14,327   +3,569

    Here I'm caught between a rock and a hard place. If I disable NoScript, I'll be inundated with truly vulgar ads. So, permissions can only be granted on a minimal, as needed, basis. FF with "NoScript", cuts right through to the free s*** , so basically, it's indispensable. :shrug:

    "Yeah though I browse through the valley of the shadow of malware, I wouldst be even more sore afraid, if Google were the angel on my shoulder".

    (I'd be filling out their stinking captchas all night).

    "Your computer is sending out requests that seem like a robot. Would you fill out this captcha just so we can be certain you're a human and not a machine". Yeah but, then I'd have to pull my typing hand out of my pants. Thanks, but no thanks, I'll hit up Bing for the search....;)

    Been there and done that, maybe 3 weeks ago. The PC shows clean with a full AVG scan, This months M$ malware tool, and CCleaner is used each and every time the browser closes.

    I was getting a Tcpip 4226 warning / error, which sources claimed could be malware generating too much outgoing traffic. But, when I backed off trying to load so many pages at once, the warnings disappeared.

    What I been able to discover so far, is XP SP-2 won't allow too many outgoing connections or it produces the Tcpip error. I just need to find out how much more resource intensive the current version of FF is than earlier versions, as I didn't really have these problems until 28.0 or 29.0.

    I was using free proxy service software, but a couple of the free servers rejected downloads from it. Then, when I tried to use the proxy for "erotic art", it blew up "Barracuda Web Filter".....:D Oh man, that's just cold and disrespectful........being trolled by your proxy......(n).
    Last edited: May 21, 2014
    Jad Chaar likes this.
  4. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,481   +975

    I have no idea then Mr. Cranky! I have failed you :(! Hey at least your post made me laugh!
  5. jobeard

    jobeard TS Ambassador Posts: 12,493   +1,430

    That's a signal of massive TCP inbound traffic.
    Slow page loading is usually due to plugins/and/or excessive Winsock filters. I'm now on Win/7/Pro but the concepts are the same. Try running w/o any plugins and you should see the difference. If so, then this is the right approach - - start pruning them out (or at least disabling).

    I've been on FF for years (even back to XP/Pro/SP2), now v 30.0, and have not see your symptom.
    I use Spywareblaster to control ActiveX components and load Spybot S&D to allow immunization (do not install the realtime, just update and immunize). You've likely seen comments elsewhere that I use the etc\hosts file to control adverts. These approaches are PASSIVE, ie take no active programs or plugins to defeat ads and other virus's and trojans.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...