1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

SSD not detected in new MOBO

By Jeanvion ยท 5 replies
Feb 14, 2014
Post New Reply
  1. My SSD is not detected in BIOS but when I run the windows CD it does recognize it as a partition. I just can't format and reinstall it, the windows message says it's because BIOS not detecting it. Anyone else experienced this or know the solution?

    My MOBO is a gigabyte GA-Z87-D3HP
  2. hood6558

    hood6558 TS Addict Posts: 252   +58

    Did you delete the existing partition? If you delete all partitions on the drive, you should end up with all unallocated space, then you should be able to format, or just tell Windows to install on the drive and it will format it. BTW a "full" format is recommended in this situation (instead of a "quick" format), even though it's a lot slower, especially if you had Windows on it before (Google it for the long explanation why). Also try a different SATA cable and port if possible, cables can go bad.
  3. Jeanvion

    Jeanvion TS Rookie Topic Starter

    So you mean I have to select my partition 2 and select delete, then I'll be able to format and install windows again?

    Attached Files:

  4. hood6558

    hood6558 TS Addict Posts: 252   +58

    Delete any and all partitions on the SSD, including the 100MB or 350MB boot partition that Windows creates automatically when you install Windows, until it's all unallocated space. Then create a new partition the size of the whole SSD. Now you can just select the new partition and click the "install Windows here' button, and it will be formatted and the little boot partition will be created alongside the main one.
  5. Jeanvion

    Jeanvion TS Rookie Topic Starter

    I did that, but now it seems that it fails to install windows each time I try.. And I know the cd is still good because I installed it succesfully on an HD.

    *edit: When I select the SSD in windows install it tells me that it won't be able to install windows on the SSD because the drive is not enabled in the BIOS. However the drive is enabled there but it doesn't show it detects it in the BIOS :-/ I tried switching SATA ports but without success. Please help me out here!
    Last edited: Feb 16, 2014
  6. Jeanvion

    Jeanvion TS Rookie Topic Starter

    After some more research I found the following piece of information:

    "Doing a bit of digging we found that some 1200 and 1600 series SandForce controllers are not fully SATA specification compliant and the previous Intel chipsets allowed for this out of spec behavior. It seems that the Z87 will not allow for this as it requires "strict adherence to the SATA specification." We did test the workaround BIOS that ASUS sent us without issues using the older F120 SSDs that employ the Sandforce 1200 controller. So obviously, this will have to be solved at a motherboard BIOS level and something to keep in mind if you have older SATA 2 SSD drives. This issue does not seem to be "widespread" though as Intel sent us a chart that contains many SATA 2 drives that have been verified to work fine with Z87 chipsets."

    My mobo is the new Gigabyte GA-Z87-D3HP, so my kingston SSD could actually not meet the strict SATA compliancy for this one... I wonder if they have a workaround for this

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...