SWAT 4 Error message and crash

By briancar89 ยท 4 replies
Mar 30, 2008
  1. Hello,

    I recently installed SWAT 4 on my laptop, since installation it has worked fine, however when I started the program it brought up a message that said that the video card did not support the game, but gave me the option to continue, once I hit OK the program ran normally with no problems. The other day I had a program stall on my laptop, and while moving to hit ctl+alt+delete the bottom of my hand accidently hit another key near the arrow keys (I'm not exactly sure which one) and the screen then went black, and came up again a few seconds later, it was very large, all the images and windows were much larger than normal. I did not know what I did, and when I went into the control panel to change the resolution it no longer offered that option. I restarted the computer and everything looked normal when it came back up, however later when I tried to start up SWAT 4 it gave me this error message:

    No Label

    Crash Time: 03/30/08 22:25:54

    OS: Windows NT 6.0 (Build: 6000)
    CPU: GenuineIntel PentiumPro-class processor @ 1496 MHz with 2037MB RAM
    Video: Mobile Intel(R) 965 Express Chipset Family (1409)

    UserName: V****g
    ComputerName: ****
    Application location: C:\Program Files\Sierra\SWAT 4\Content\System\

    SWAT Build Number: 31973

    Error setting display mode: No fullscreen display modes found (D3D_OK). Please delete your Swat4.ini file if this error prevents you from starting the game.

    History: UD3DRenderDevice::UnSetRes <- UD3DRenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine

    I tried to uninstall and reinstall the program and it had no effect.

    Thanks for any ideas and replies!
  2. SOAD

    SOAD TS Rookie Posts: 55

    do this as it says. Swat4.ini found at : c/program files/sierra/swat 4/content/system

    it is the file called "Swat4" which has a notepad type icon with a cog and its "type" is configuration settings.

    delete that and then start the game. all settings should have reverted to default.
  3. briancar89

    briancar89 TS Rookie Topic Starter

    I checked through the directory and i do not have a Swat4.ini file, the closest one to it was Swat4.int. I moved that file out of the directory and tried to start SWAT 4, but the same error message is coming up.
  4. SOAD

    SOAD TS Rookie Posts: 55

    its the one called "Swat4" below the icon that starts the game. it does not say .ini after it but its "type" is configuration settings (if you organise by type) and when you right click and go to properties its says "type: configuration settings (.ini)" so try moving that file out

  5. briancar89

    briancar89 TS Rookie Topic Starter

    I did all that like you posted previously, I tried sorting the files alphabetically, and by type, and I do not have a swat4.ini file. I also tried a search on the hard drive for swat4.ini with nothing. Is it possible that I could have a different version where there is a different file name?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...