Tech Stocking Stuffers: 18 awesome gifts under $50

Thumb drive problem: device not responding

May 5, 2008
  1. Hi, ALL,
    Here is my problem.
    I have a thumb drive. Everything worked fine until yesterday.
    Yesterday I came home, put the drive in the USB slot of my DELL laptop, and... nothing happened.
    The drive has a light on top. Usually it is blinking when it goes through mounting process, but not yesterday.
    I tried one of my desktops computers, but with the same result...

    Is my drive dead?

    Thank you.

    ONEEYEMAN TS Rookie Topic Starter

    One other thing I want to mention is:
    The drive is not recognized even in Linux. I tried to put it in the USB device of Linux box, and nothing happened. The light on it is still dead.

    The drive itself has an 'ext3' partition from Linux's fdisk (type 87). I used Gentoo fdisk and then formatted it using:

    mke2fs -j /dev/sdb1

    Now is there any software in Linux that can be used to check this stick?

    On Windows I was using the ext2fs driver to write on the stick. (ext2 IFS driver).

    Thank you.
  3. jobeard

    jobeard TS Ambassador Posts: 10,845   +897

    as two entirely different systems have the same symptom -- looks like it's Dead :(

    ONEEYEMAN TS Rookie Topic Starter

    That is indeed :(
    So, I guess the only thing left is to send it to manufacturer and get it exchanged...

    Problem is I don't know what might've caused it.
    Is it possible that it becomes dead by removing it from PC during the access try?
    Or maybe it was pulled incorrectly?

    I just can't think of anything else....

    Thank you.

    P.S.: I don't have a Win98 system unfortunately. What are my other options in recovering the data?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...