Toshiba Satllite preboot freeze with CD drive

By sethbest ยท 5 replies
Apr 8, 2011
Post New Reply
  1. I run a refurbishing division of an electronics recycling and disposal firm, and as such I work on restoring laptops and desktop computers. Of the last batch of laptops I started fixing two were relatively new satellite A215 model laptops, both of which were having startup issues. After stripping them down seperately I finally figured out what was making them freeze, but cannot figure out why, or how to fix it.

    Essentially both systems will freeze showing the toshiba startup screen, but before reaching the bios or post information if they have optical drives plugged in. If no drives are plugged in they boot and run fine. One of the systems work sporadically with the optical drive, even installing an operating system before it stopped working entirely, while the other will simply not move past the start screen with the drive in.

    Both the bios and the boot menu will not come up when the symptoms appear if the optical drives are plugged in. Mind you these are two seperate optical drives, and I tried switching them to identical results. If you hit the f2 or f12 keys for bios or boot they will say "loading bios" or "loading boot menu" on the bottom of the screen, seemingly indicating that its getting hung up early on in the post but not failing to the extent that it won't take keyboard commands.

    I googled around with different search terms in regards to this but found nothing. When I head back into the office next week I will try some different cd drives, but it seems unlikely that both of these dvd drives were faulty in an identical way, and if they were I have never seen an optical drive fail in a way that completely halted startup.

    I am perplexed, and would be interested to hear back from anyone with ideas, suggestions, or similar experiences.
  2. Mark56

    Mark56 TechSpot Paladin Posts: 1,886

    Are these optical drives the ones that were installed in the laptops?

    They may both be faulty, despite this being a rare coincidence.

    Look in Device Manager and delete everything under the CD/DVD drives and then reboot (with the drives fitted) so windows will reload the drivers.
  3. sethbest

    sethbest TS Enthusiast Topic Starter Posts: 79

    These are the original dvd drives, and I am testing these systems without hard drives so the windows drivers do not factor in. I've also switched memory modules in and out to rule out a memory error.
    You may be right about the faulty coincidence, but I think at the moment I'm leaning towards some internal problem, such as a short on the motherboards. Since they are near identical models a design flaw may be present in both.

    Just a pretty weird situation.
  4. sethbest

    sethbest TS Enthusiast Topic Starter Posts: 79

    Tried multiple known to be working drives to no avail. Both Satellites simple will not get past boot screen or show post when a cd drive is plugged in. If no one has any insights about this does anybody know specific usb cd drives that will boot with toshiba satellites? my sony usb dvd-rw is not detected in bios.
  5. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Yes sethbest,
    I would say that the motherboards are the issue
  6. Lokalaskurar

    Lokalaskurar TS Enthusiast Posts: 544

    From the looks of it (i.e. what you're saying), it sounds like both motherboards have shorted. By default, a faulty CD/DVD optical drive will not cause a complete system halt on startup. Personally, I've seen everything from broken connector pins to cracked lenses - as the drive is 'merely' a peripheral, it does seem like the motherboard itself is causing the trouble.

    A clue to what may be the problem; an optical drive does require a 'logical peripheral slot', perhaps that is why it works without an optical drive. My suggestion: try removing the HDD but leaving the optical drive in, and boot from a start-disk. Does it work? Not?

    Also, the USB-optical drive should not be a problem. But as it clearly does not work, then yet again it may have to do with this 'logical peripheral slot'. A suggestion would be to try with an external USB-HDD as well, does the same trouble appear? Because this sounds very much like a short on the southbridge connector, or something related to that.

    Another (non-related) suggestion would be to try out the optical drives in another laptop, provided it's possible - to see if any of these original drives are salvageable or not for future usage.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...