TP-Link GB LAN Drivers "corrupted or missing"

By DjKraid
Mar 24, 2009
  1. HI!

    Here again asking stupid questions...I have a "TP-Link 10/100/1000Mbps Gigabit Ethernet PC Card" and first I installed the original drivers from the cd that came with the card and got an error message:

    Windows cannot load the device driver for this harware. The
    driver may be corrupted or missing. (Code 39)

    Click Troubelshoot to start the troubelshooter for this device.

    Ok so I click...and then i only get an empty screen...

    So I downloaded the newest drivers and installed them but it says still the same...

    So the next thing I did was /google and from there I found loads of random sites and then ofcourse Microsofts support I tried it...and it says 1st:

    Click Troubleshoot to start the Troubleshooting Wizard. The wizard asks you some simple questions and provides a solution to your problem based on the answers that you provide. If the Troubleshooting Wizard is not available, go to step 3.
    Follow the resolution steps provided by the wizard to resolve the problem.

    Yeah! good luck...when I only get an empty window where even not the search works...

    So what to do??

    btw...the card is installed in a "Dell Dimension XPS T550" and before that it was in my other computer and worked just fine..!
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    last time i saw this i was trying to get a WIFI nicon XP working on a nasty pcworld laptop, it was built for vista and no matter what i tried i couldnt find the drivers for it, all the ones i tried gave me the code 39 error.

    The cure, i used the restore disk and driver disk to put Vista back on the laptop and it worked fine.

    Seems to be a case of find the right driver for it, although its possible that the card has gone faulty, have you tried it back in the PC to make sure.?
  3. DjKraid

    DjKraid TS Guru Topic Starter Posts: 551   +26

    so basicly i should put windows 98 back in it :D

    but i talket with a friend and he said that i should update the bios...but i can't find an uppdate for it..?
  4. DjKraid

    DjKraid TS Guru Topic Starter Posts: 551   +26

    i just flashed the bios but no results... :/
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...