Trouble commenting using copy and paste

By cliffordcooley · 10 replies
May 2, 2012
Post New Reply
  1. I just tried copying a quote and pasting it in the text editor. The copied text is replaced with a single word.

    I often copy quoted text from the editor after clicking reply. Then I will backup and reply to another comment to add the copied text. I'm not sure but I think I have done this recently with the new board.

    I'm also wondering if it is possible for the user to increase the size of the Editor when required? I'm finding the size of the editor to be a bit cramped, with no way that I can see to increase the size.
  2. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,676   +991

    The one word thing doesn't happen to me, and I've tried in various browsers. What are you using?

    I did make a change last night so formatting is removed from pasted text by default, which was always intended. In this way we also remove the option of different font families or text size which shouldn't be options here.

    We are leaving other formatting, including color which wasn't an option in vb.


    I second your request on the larger text editor, looking into it soon.
  3. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,738   +3,706

    I'm using Opera 11.62. The copied text was including the quote tags around the text. It was strictly text without any formating.

    This is confusing, I just tried here in this thread and pasted without issues. However in this thread I get "tiny_mce_marker" when pasting. Even after getting "tiny_mce_marker", I came back here while the text was still in clipboard and pasted the text.
  4. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,676   +991

    So it was a one-off thing?
  5. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,676   +991

    Still a work in progress, but I may have fixed the quote button, the property of the self-expandable form, all while removing some text formatting options that I wanted to get rid of from stock.
    cliffordcooley likes this.
  6. cliffordcooley

    cliffordcooley TS Guardian Fighter Topic Starter Posts: 9,738   +3,706

    So far so good, I went to the thread linked above and couldn't reproduce the issue I was facing.

    Thanks Julio for all your hard work trying to satisfy the little peons such as myself. :)
  7. bobcat

    bobcat TechSpot Paladin Posts: 688   +67

    I don’t experience the single word problem, but a related one. If I first type the text in word, then copy and try to paste it in the quick reply space, I have to right click-paste several times before the text appears. I’ve just tried it with this post and it took 4 attempts to paste it.

    XP, Opera

    EDIT: I've noticed that if I first hit e.g. the space key and then paste the message, it works first time.
  8. mario

    mario Ex-TS Developer Posts: 399   +17

    My text editor expands automatically when I've used the provided space, is this not happening to everyone?
  9. Per Hansson

    Per Hansson TS Server Guru Posts: 1,960   +218

    It does for me too, XP x64 & Opera 11.62
    Did Julio just do something to fix it perhaps?
  10. Julio Franco

    Julio Franco TechSpot Editor Posts: 7,676   +991

    I fixed it last night, per my message above. TinyMCE is a weird animal though, so tweaking it has proved more cumbersome than I imagined.
  11. mario

    mario Ex-TS Developer Posts: 399   +17

    Yeah, that's why I used CKEditor for our CMS :cool:

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...