Two Windows XP Home Problems

By thehighroad ยท 17 replies
Jun 13, 2009
  1. EDIT: Only one problem now.

    In device manager I have a "NVIDIA nForce Networking Controller - Packet Scheduler Miniport" that I want to uninstall. This device existed on my old motherboard, and my current motherboard has the RTL8111C chip. Why it tell me "Failed to uninstall the device. The device may be required to boot up the computer"???
    Currently, I simply have it disabled.

    I would really appreciate anyone's help!
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    1) have you checked the speakers,,,daft question i know ...

    2) if it aint in use and its not an issue leave it, windows wont let you remove it so i wouldnt worry.
  3. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    I completely removed all of my Sound Blaster drivers, moved the card to a different port and installed them again. It works fine; problem 1 solved!

    Problem 2: So long as it isn't causing me any serious problems, I suppose I'll leave it alone. Still though, I'd remove it if I could...
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    There are several odd things based on what you say

    Odd thing #1: A "packet scheduler miniport" sounds like a "logical" device created by software.
    >> In device Manager, rt click Properties->Details. Look at the device instance id
    >> Device IDs all begin with an "enumerator" of the form xxx\
    >> A physical hardware network adapter will start PCI\ or USB\ depending on whether it connects to the computer's PCI or USB bus
    >> My guess is the device ID for the device you mention will show it's a root\ enumerated device (which are software devices. Any number of software devices can exist.. but all your Nvidia root\ enumerated "software" devices will be associated with a physical Nvidia hardware device you should also find listed)
    >> Which begs the question: aren't there other Nvidia network devices listed? One should be the PCI\ or USB\ physical device

    Odd thing #2: If, in fact, a physical Nvidia device doesn't exist,
    those Nvidia drivers should not have ever gotten installed or at minimum you should be seeing the yellow icons appearing with it in Device Manager as you claim a driver with no device???!!

    Are you also seeing a Realtek device under Network Adapters? Sounds like you have two physical network adapters connected?
  5. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    Device instance ID: ROOT\MS_PSCHEDMP\0000

    In the General Section it says:
    Device Type: Network Adapters
    Manufacturer: Microsoft (What the hell?)
    Location: Unknown

    My old motherboard was an MSI K8NGM2-IL with the nForce 410 chipset, thus the driver.

    My current motherboard is a Gigabyte GA-EP45-UD3L, which has the Realtek RTL8111C PCIe Gigabit lan chip... no where near the same; and it is installed in device manager. (Chipset Intel P45, ICH10)

    Keep in mind, I kept my installation of windows and simply moved my harddrive to this new motherboard (I had uninstalled all of my nForce chipset drivers in advance).

    Just to clarify there is only ONE (1) physical network adapter present. I have the following under Network adapters:

    NVIDIA nForce Networking Controller - Packet Scheduler Miniport
    Realtek PCIe GBE Family Controller
    WAN Miniport (IP)
    WAN Miniport (IP) - Packet Scheduler Miniport
    WAN Miniport (L2TP)
    WAN Miniport (PPPOE)
    WAN Miniport (PPTP)

    Edit: I have a Nvidia 7800GT video card. But I have uninstalled the drivers and reinstalled them with a clean install when I recently updated them (used driver sweeper). Did not solve the problem.
  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm.... This is my thinking/next guess to try...

    By default, Device Manager only shows devices that are "connected" (also called "present")
    >> Your NVIDIA video card is a separate and independent device from a NVIDIA network controller
    >> If your physical NVIDIA network controller is no longer physically there it is "nonpresent". Meaning the driver may still be installed but why it's not appearing in Device Manager

    See this link
    Follow the instruction to how non-present and Hidden devices. Does the physical nvidia network controller then appear as a non-present (aka "ghost") device? If yes, then uninstall it!!
  7. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    Hello LookinAround,

    Thank you for your continued support! I tried the above and wound up unsuccessful. I have attached a screenshot of the situation as well so you can have a look. Again, this controller IS NOT present on my system, an who knows why Windows is protecting it.

    Have a look at my motherboard if you feel the need to:

    There is no add-in card either. Again, I have an SB Audigy 4 (PCI) and a NVIDIA 7800GT (PCIe).
  8. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    OK... Here's "another Hmmmm..." from what i see

    1. Your device manager snapshot shows Other Devices. These will be Device IDs that Windows detects which it cannot match to a driver (thus it doesn't know for sure what it is so calls it 'Other Devices'.) We'll be looking into just what's listed in there

    2. I'm also wondering (again, just speculation) if maybe the issue is: Your registry still has entries for drivers (e.g. the Packet Scheduler Miniport) which point to driver files which actually no longer exist. I wonder if Windows really can't uninstall it because its "driver chain" is corrupt and the message it ends up showing you (about can't uninstall 'cuz it's needed for reboot) is simply the wrong reason why. (Well, we are kinda guessing that can't really be the right reason it can't uninstall because pretty certain is really NOT needed for boot!)

    Will look into it abit more and get back to you next couple days. If nothing else will give you instructions on how to install/use a MS tool which will dump much detail into a report about your devices, drivers and all the detail that would otherwise require many mouse clicks and searching through Device Manager. That might provide the detailed info needed to fix this puppy.

    /* EDIT */
    Note that things in Other Devices sometimes are the cause of problems. But not always. The MS tool would also provide me info on everything appearing under that category (tho maybe you can tell me to start: Does the category exist ONLY when you show hidden devices?? Or whether you show hidden or not?)

    /* EDIT *2 */
    btw.. As to the driver saying it's from Microsoft: That's likely because even tho is a Nvidia controller that particular "software" created device is using a generic MS driver. Is not unusual for Nvidia to provide their own driver for the physical network device controller but Nvidia didn't supply a driver for some of the logical "softtware" network functions provided by their device. The logical functions then default to using generic MS drivers for that software function (eg. the miniport scheduler)
  9. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    The NVIDIA network controller shows up regardless, it is considered by Windows to be present and "working" in my system, and I currently have it disabled.

    The "other devices" do not appear unless I have the hidden hardware devices in view. At some points I did have unidentified hardware before installing drivers (i.e. when I wanted to try out my azalia audio, hated it; and disabled it in BIOS).

    Just to make things clear, there are no hardware conflicts and every piece of my current hardware is recognized, installed, and working well.
  10. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    If Other Devices only appears when showing hidden files option.. then is OK. not a problem

    As for what appears in Device Manager, (see my jpg attached and to clarify a few things)
    >> Note my device manager has many devices listed under Network adapters but
    >> Only two entries are for the physical hardware network controllers
    ===> One is a LAN controller and the other is Wireless controller
    ===> Note the Details properties windows i also show to the right in my .jpg. Note the first two entries are PCI\ enumerated devices and these are the two drivers for the two PHYSICAL h/w controllers
    ===> I also show Details for my wireless packet scheduler device. Which you'll see is also another root\ enumerated (i.e. a software device)

    So when you say "your network controller always appears" i assume you only mean the software device? (you never see a different entry for the physical device?)

    And when you say "it is disabled" i assume you disabled it AFTER the pic you created as (e.g. in my example for my Wireless) i expect to see a red X in Dev Mgr for any disabled device
  11. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    Yes, i have disabled it and it has the red X over the card symbol near the name of the device.

    The NVIDIA card is enabled or "installed" according to windows b/c the card logo is not faded, and in full color. This device, again is NOT pci enumerated, and is solely software based because no such physical device exists, I have confirmed this several times.

    See the attachment so you too can confirm this, so that we can move on.

    I do not have a wireless network device installed USB or otherwise. I have a direct connection to my wireless LAN router via my WAN port. That's it. If you have any ideas as to how to FORCE UNINSTALL, I think that would probably be the best piece of information at this time, as I have seen these kinds problems all over the place through research but I could not quite find one exactly like mine.
  12. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    1) Do this FIRST. Open Control Panel->Add/Remove Programs. Do you have any Nvidia Networking Software still listed/installed? If yes, uninstall it. As it might be yet another reason why DevMgr won't uninstall.

    2) I haven't looked at your motherboard but figured is best to just ask you to please confirm: Are you running 32 or 64 bit Windows? Click for how to determine whether you are running 32 or 64 bit windows (as my instructions on using the devcon tool differs between the two)

    3) Do not try to remove/change on your own (but just fyi) you're gonna find
    >> all your root enumerated device drivers listed in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\
    >> And would expect you'll see multiple Miniport scheduler entries (numbered 0000, 0001, etc) in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\MS_PSCHEDMP

    in any case, check for Add/Programs and confirm 32 vs 64 bit so i can give you the right info for next step
  13. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    There are no more drivers pertaining to NVIDIA chipsets/network devices.

    I am using Windows XP 32-bit, and its an OEM version.
  14. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    One more thing to please first check manually

    Control Panel->Network Connections

    Rt click Properties for each connection listed. Confirm none of Network Connections that appear still refer to the Nvidia controller

    /* EDIT */
    Ooops. i meant Nvidia in above (and edited my post accordingly)
  15. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    Have a look at the screenshot. The Local Area Connection appears perfectly fine. Although the disabled "Internet Connection" does not refer directly to NVIDIA it has me wondering. What if, that NVIDIA network device in device manager is really a core component of Windows and it's a software device that's required to connect to the internet. What if it never got renamed in device manager after it was uninstalled; perhaps because of a bug or something. Is there any way to rule this out?


    Edit: I just re-enabled the NVIDIA device in device manager to see if the status of "Internet Connection" changed from disabled to enabled. Whether or not the NVIDIA device is enabled, the status of Internet Connection remains disabled.
  16. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    I think go it! (<crossed- fingers>)
    Let's see if this works for you and then i can explain (if you want).

    1. Enable the device (you had it disabled at one point)
    2. Control Panel->Network Connections
    3. Rt click Lan Connection->Properties
    4. Highlight QOS Packet Scheduler then hit Uninstall button.
    5. Wait for uninstall to complete. then hit OK

    Now go check on your Network Adapter devices. What ya see now?
  17. thehighroad

    thehighroad TS Rookie Topic Starter Posts: 45

    Wow, I thought I had already tried that, but I gave it a whirl anyways.

    Only thing to note that I did extra is after uninstalling the QoS packet scheduler, I clicked Install... --> Service, then, Add... --> Then I installed the Digitally signed QoS packet scheduler that was available courtesy of my Realtek drivers. I restarted my PC then...

    ========================PROBLEM SOLVED============================

    Thanks, LookinAround.
  18. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Glad to help :grinthumb

    And fyi (just briefly) for anyone now or in the future reading this thread..
    1. By looking at those entries in the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\MS_PSCHEDMP
    2. I found each instance of the device MS_PSCHEDMP uses the driver (stored on disk) in C:\Windows\system32\psched.sys
    3. Checkout this tool Serviwin to get much detailed info about your Windows drivers and services
    4. That's how i found psched.sys is actually (and more commonly called) the Qos Packet Scheduler!
    5. Which is why i realized Windows wouldn't uninstall those "miniport packet schedulers" until the Qos scheduler was first removed! (in fact they're actually one and the same thing. Gd only knows why Windows chooses to refer to them with two entirely different names!)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...