Urgent help with my Maxtor 250 GB external drive

By DLambie ยท 12 replies
Mar 2, 2010
  1. I have a Maxtor One-tough 250 GB external hard drive been work fine and sound fine,

    I was tansfering data onto on drive from computer 1 to computer 2 and once it was done copying all the data, I checked in Windows Explorer too and tried to open stuff and all was good, I wanted from computer 1 onto the external drive so I properly disconnected it and everything plugged it into computer 2 to take the data I wanted off of it however I plugged it in says it needs to be formated. BIG problem I have is I need this data and since I seen the data was properly tranfered to my external in which I opened a few documents to see I formated computer 1.

    Can any one help me please why will my external drive not been able to be read anymore??

  2. gguerra

    gguerra TS Guru Posts: 319

    Can you see the data on your external with computer 1? (the pc you used to write the data)
  3. DLambie

    DLambie TS Booster Topic Starter Posts: 83

    no that is the strange thing.

    As well plug it in the computer eads as Maxtor and all in task bar but try to open it in explorer it just wants to fomat it - does this on both computers.

    Maybe it is the exteral drive case not functioning right -- as had a 1tb external do this too and took drives out of case put into another one and they worked fine
  4. gguerra

    gguerra TS Guru Posts: 319

    If the hardware is working, then I would look at the OS being able to recognize the drive correctly.. Plug it all in and see if it appears under disk management.. You may need to assign it a different drive letter.
  5. DLambie

    DLambie TS Booster Topic Starter Posts: 83

    the thing is it has a drive letter assigned to it but I do not want to format this drive.
  6. DLambie

    DLambie TS Booster Topic Starter Posts: 83

    oh I just looked aain in Disk Management it says K: is RAW format and not NFTS or FAT (which it was) what is RAW
  7. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Uh oh.

    "Raw" means that Windows doesn't think there's any filesystem. This can happen if the drive is corrupted so Windows no longer recognizes the filesystem that used to be on the drive.

    You can try TestDisk for data recovery. Never used it myself but see many have used it with good results.
  8. DLambie

    DLambie TS Booster Topic Starter Posts: 83

    FYI: I been searching the internet and cam across, below, this wonder if it could be true may try that after i try the test feature you suggested.


    Western Digital external USB 500GB disk has been working for months
    on a variety of Windows XP Home & Professional machines but all of a
    sudden, it is found in Windows but Windows says it's a RAW disk with
    no data.

    Can a virus convert a perfectly good disk into a "raw" disk (whatever
    that is)?
    How would I recover the data (some of which is not backed up).

    Please help ...
    Reply to this:
    probably not a virus...

    First...try it on another machine...
    if the problem remains...

    If you are lucky the problem could be with the USB interface of the external

    Remove the drive and install it internally
  9. hughva

    hughva TS Rookie Posts: 58

    You can often read these disks with a Linux Live DVD like Ubuntu or KNoppix.
  10. DLambie

    DLambie TS Booster Topic Starter Posts: 83

    sweet - I actually have linux installed on my one computer - so if i boot to Liux an pug my external in it will read it? then can I move those file ??
  11. hughva

    hughva TS Rookie Posts: 58

    It's very likely.
  12. DLambie

    DLambie TS Booster Topic Starter Posts: 83


    So Linux will read Windows data?

    I think I figured out what went wrong the external drive was unplug without click on the Sately Remove Hardware.

    If this is the case how do I assign a drive a letter so wiindows can read it?
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Yes, unplugging the drive without using the safely remove icon can corrupt the filesystem

    I think you need to run a data recovery tool (which specifically try to read "raw" drives looking for the old filesystem and data. I've never personally used any of the tools below but have read people have often had good results using them

    Freeware Tools
    => Download TestDisk and PhotoRec freeware tools. (The one download gives you both)
    => If TestDisk can't see the drive under Windows, you can also try under Linux. See [post=720766]this post[/post]

    Try It and Buy It Tools
    => I've never used either but
    > I've seen people often (not always) post good results after using the two commercial tools listed below
    > The tools will report (for free) the names of the files it can find. You'll need to buy it before it attempts to recover those files
    > Note: Finding lost file names is a good start but still doesn't guarantee the results

    An extra step of caution
    it's also good to be cautious before attempting recovery by first creating a disk image of the current drive so no matter what you do/guess/try during recovery attempts, you can at least still restore the current drive image. EASUS Disk Copy is freeware to image backup the drive
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...