USB ports stopped working completely

By Throwing Stones
Jul 23, 2008
  1. I'm not even sure if this is the right place to post this but if I hadn't shaved my head, I would have been ripping my hair out by now.

    I used a "mass storage device" for my SD card to put pictures from my camera onto my PC. This always worked fine until that one fateful day... I plugged it in and a bobble came up saying it exceeded the limit the device. Didnt know what this meant since I honly had a few pictures on the card. I removed it, and put it in again, this time it sorta freaked and the bubble popped up twice, I tried removing it again, but it wasnt responding and eventually froze my computer, so I pulled out the device and rebooted.
    Upon restart i noticed that the device wasn't being read at all when i plugged in...
    so I went to check the device manager...but the mouse wasn't working, or keyboard, or anything else i tried to plug into the USB ports.

    device manager says "device is working properly" for all 5 ports, but no device ever gets read when i plug it in. no light on the device comes on, no bubble, no nothing.

    I deleted the USB root hubs and restarted, they reinstalled, but no devices work.
    I went into power management and made sure that "allow my computer to shut this device off to save power" was OFF... still no luck.

    I ran some Belarc Advisor on my computer and it recognized all the USB ports.

    I don't know what else to do
    ..can anyone help??
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...