Vista doesn't recognize USB devices

By gammerx · 11 replies
Aug 18, 2010
Post New Reply
  1. I have a dell inspiron e1505 running windows vista and for the past few weeks, none of my USB devices that I connect work, I have tried to connect 2 different webcams, my hard drive and my phone, while they do receive power, windows says that the device has malfunctioned and can't recognize it. Then windows goes on to "install" drivers however it is still read as "unknown device" I have tried several things including registry booster (but i didnt get all of them fixed) and even reinstalled vista. Any help?
  2. hughva

    hughva TS Rookie Posts: 58

    Please don't use any registry repair programs. They are as likely to destroy as to repair.
    Try deleting(Uninstall) all the USB ports in Device Manager and rebooting.
  3. gammerx

    gammerx TS Rookie Topic Starter

    Ok I will try that.
  4. CAMusing

    CAMusing TS Enthusiast Posts: 179

    It never ceases to amaze me how many people think using a registry cleaner is the first thing to do when something goes wrong.

    Using a registry cleaner is the last thing you want to do!
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    See [post=875300]How to Cleanup and Remove old USB Storage Drivers[/post]

    See [post=751005]How to Reinstall Your USB Controllers and Motherboard Chipset Drivers[/post]

    And be sure you're current with all Windows Updates and you have SP2 installed.

    If you still keep getting "Unknown device" do post back and let us know
  6. gammerx

    gammerx TS Rookie Topic Starter

    I was searching online for a solution, and found someone with basically the same problem as me, and they posted to use the program from uniblue.
  7. gammerx

    gammerx TS Rookie Topic Starter

    Going to go try it now thanks sir
  8. gammerx

    gammerx TS Rookie Topic Starter

    didnt work :/
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Darn :(

    See [post=766270]How to recover your folders/files when Windows won’t boot[/post]

    Follow the 2nd part of the Guide so you can create and try booting from a Knoppix CD. Then test your USB ports under Knoppix
    > If they work under Knoppix, at least you'll know it's a Windows problem
    > If they still fail under Knoppix as well it's probably a problem with your computer :(

    /* edit */
    Also.. you'll probably only be able to test standard USB devices (using standard drivers) under Knoppix (like trying a USB flash drive or US external HD or USB CD/DVD ROM). Since you're booting from a CD, don't know if things like a USB web cam would under Knoppix but standard USB devices certainly should
  10. gammerx

    gammerx TS Rookie Topic Starter

    ok, also when i disconnected(uninstalled) the usb root hubs, it was fine but when i uninstalled 2 controllers, it would reinstall the first then if i did the third, it would reinstall the second, before i got to reboot. is that a problem?
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Hmmm.. It's been awhile since i last reinstalled all the USB controllers myself (and wrote the Guide) so i'd have to recheck... So I think it's worth you first creating and booting from a Knoppix CD (per my prior post). As if your USB drives still fail under Knoppix, we'll know it's a not a Windows problem so need no to try a controller reinstall if that;s the case

    /* edit */
    And since this is a latpop, right? I'm assuming you're not trying to reinstall USB with any USB devices installed, yes? Tho in any case, still best to see what happens if you boot from a Knoppix CD
  12. gammerx

    gammerx TS Rookie Topic Starter

    Im going to try the Knoppix thing soon, yes its a labtop and all the USB devices were removed

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...