Volume Shadow Copy Causing STOP 0x00000019 "Bad_Pool_Header"

Not open for further replies.
I did mine from within windows using the MaxBlast 5 tool from Seagate (oem from Acronis)...and, by the way, I went from PATA to PATA...even the same size disc...200GB to 200GB...both Maxtor drives...

Let me know how it goes with Ghost, as that is what I use for backups...or at least used to...

(Sure sounds like this is really an Acronis issue...surprised they haven't stepped up and worked on this...it is very repeatable !!!)
Me too: BAD_POOL_HEADER error after Seagate DiscWizard SATA to SATA clone

Add me to the list of people who are experiencing a BAD_POOL_HEADER error after having done a disk clone with a Seagate / Acronis product.

For me, I used the Seagate DiscWizard (really from Acronis) to clone a 160 GB Seagate SATA drive to a 500 GB Seagate SATA drive.

Now when I try to do a backup or copy operation in NovaBACKUP I consistently get the BAD_POOL_HEADER BSOD when it runs. :mad:

I too feel that it is up to Seagate and Acronis to own up to this problem, thoroughly investigate it and provide a simple fix (short of reinstalling Windows on a clean disk).

I will submit support requests to Seagate and Acronis for whatever good it will do. Maybe if we keep up the heat, they will do something.
That is what I have suggested. I just received a reply back and I am going to let them know more about what happened. Maybe if enough people submit a report to them they will see it is a wide spread problem and will fix it.
I spoke with Apricorn again about their Acronis OEM SW for cloning disks and the tech said to try unchecking all startup items in msconfig before cloning from the CD (not from within Windows). He wasn't guaranteeing anything - just suggested that as something to try - apparently one of their customers had told them that it worked. He seemed to be fairly knowledgeable about both Acronis and Norton Ghost. Apparently the two products clone quite differently so Ghost might work. But, and this is important - Ghost 12.0 comes with its own huge set of potential problems.

TechSpot won't let me insert a link until my post count reaches three or greater (this is my second) but there are some very revealing reviews about Norton Ghost 12.0 at Amazon.com - I'll make a couple more posts and then give you the link to the reviews.

I haven't tried Apricorn's suggestion yet and I'm no longer sure I want to try Norton Ghost - but I'll advise if I try either.
Has any one tried . . .

In a hopless attempt to get my systems working without having to re-install all my programs again has anyone tried doing a "repair" of the existing windows installation? IE starting from the XP install CD and instead of installing newly, just do a repair of the existing installation?

To help others I can offer the following information since I have the exact same problem on two completely different systems:

Going from PATA to SATA does not matter as I have done that on one and PATA to PATA on the other.

Video cards/drivers does not mater as I have one ATI and one nVIDIA.

CPU/motherboard does not matter - two completely different rigs.

I also tried re-installing SP2 and that did nothing.

Other fourms suggested turning off the MS indexing service and that did nothing as well.

Also tried manually starting the VSS and Shadow copy providers without results.

All I can conclude is that the Discwizard/Max Blast/Acronis made some very small/minor change to the disk that causes the shadow feature to crash.

I did read somewhere and I can't find where I read it that this software somehow messes up the DOS names for the files on the disk. This might explain why there are no errors from XP in normal running. However I have not figured out how to check/fix this.
kam33mitch, I just tried Windows Repair right now and it did NOT work for me. I'm still getting BAD_POOL_HEADER errors when doing backups or copies with NovaBACKUP with the "Enable Open File Copy" option checked. This is VERY frustrating! :-(
I suggest to do what I did and just re-install windows and install all of your software again. I would suggest to make a copy of your "C:\Documents and Settings" folder somewhere off of the C drive. You can restore all your Documents and Settings when you install Windows XP by copying over the files back over. Some files you may not be able to copy but they will be re created when you install Windows XP again.

I would also suggest to submit a tech support request to Seagate. If enough people send the same sort of problem than Seagate will have to fix the problem with their software. I do understand where Microsoft comes from because SCSI and SATA are not built into Windows directly so it can cause a problem with a clone. We are mixing different Hard Drive Interfaces together on the boot drive. Especially when the Windows Kernel is build at the time of install meaning it is working with whatever Hard Drive Interface the boot drive was when Windows was installed. This doesn't get repaired when you do a in-place install. It replaces everything but the kernel (also called HAL - Hardware Abstraction Layer).
Seagate support

Oh, I have a submitted a question to them and it's been four days now with no response.

I still have my original drive so I can go back anytime I want and just copy my new data files back but the whole point was that it was time for a bigger drive. For me, re-installing windows would be the last, last resort. I hate having to re-authorize all my software and go through the hours of swapping CDs & DVDs. There has to be an easier way, right?
It took them about a week for them to respond to my question. I'm still working with them hoping they can offer an answer or even a bug fix.
response from Seagate

Well my first response was not all that great:

Thank you for your E-mail inquiry. With regards to your query, I would be glad to assist you.
I understand that you are having trouble using the MS backup utility in XP, let me inform you that if the drives are working fine when you are not using the MS backup, then there is no problem with the cloning, the drives are working fine. As for the BAD_POOL_HEADER error, Microsoft has identified this problem and you may call Microsoft more assistance on this error.

The only other question I have at this point is if everyone having these problems used the boot from CD option. I'm wondering if I would have better luck running it straight from windows.

Any comments?
No - I did not boot from the CD. I cloned from within XP Professional SP2.

I have received some reasonable responses from Apricorn (their product includes Acronis version 10) but have not been able to try them all yet.

Before you clone - make sure all BIOS passwords are turned off and uncheck all Startups in msconfig - I haven't recloned yet so I haven't tried these.

Suggestion for after you have cloned - increase IRPStackSize by 3 at HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters (insert it if necessary - default is 15 decimal, max is 50 decimal, see Microsoft knowledgebase Article ID : 285089 ) - this didn't stop my Bad Pool Header problem.

I have a perfectly reproduceable problem. Start Windows Backup Utility and in less than 30 seconds I get a BSOD Bad Pool Header 19_20.

I'm getting ready for a trade show next week so I won't be able to try anything else until I get back. Then I will try unchecking all Startups and then clone again - I already know that no BIOS passwords are enabled.

If that doesn't work, I may try Norton Ghost but I'm nervous about all the bad reports I mentioned in a previous post.
I Think I Solved It!!!

I won't bore you with the details of how much digging and where I found this but I've tried it and I can now do shadow copy backups again.

Try the following:

1) regedit from the run menu.
2) goto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE-10318}
3) Export this key so you have a backup of it. (I know this solves the MSbackup but I don't know if other problems will pop up.)
4) delete the key "UpperFilters"
5) re-boot
6) My computer did a "Found new hardware" when it re-booted and required another re-boot.
7) Go ahead and re-boot
8) Run your backup software as ususal.

If you want to know how I found this . . .

This key is the device manager for the disk drives. I found this from a thread where the CD drive was causing the same BSOD and the solution was to delete this key from the CD ROM device manager registry. I went down a couple and saw that the disk drives had the same filter and had an entry of "partman". After deleting and re-booting my PC is behaving like it used to. Obviously I'll do some more testing but the BSOD is gone and I'll take it. Anything to not have to re-install everything. I KNEW IT HAD TO BE SOMETHING SIMPLE!!

I really hope this works for everyone else!!
Eureka! kam33mitch found it!

I can verify that kam33mitch's solution DOES WORK! No more BSODs after this procedure. Great detective work!

I did find a side-effect on my system. Explorer now shows three new "Local Disk" entries (E:, G:, I:) that appear to be small FAT partitions on each of my 3 NTFS drives (1 internal, 2 USB). I believe these were hidden before and contain the Dell re-install files.

I tried using the Computer Management\Storage\Disk Management console (right-click My Computer > Manage) to hide these partitions somehow, but didn't have any luck. (Their context menu just has a "Help" item, nothing else - unlike the NTFS partitions.) Any advice on how to hide these again would be appreciated.

Three cheers to kam33mitch!!!
Before we go any further with this, can LarryD and kam33mitch tell us what filter driver values were in upperfilters before they deleted it? PartMgr is supposed to be there and deleting that may be why LarryD is now seeing formerly hidden stuff. I am wondering if there was an Acronis filter driver name value there and maybe it was only necessary to delete that name value. The only value I have there currently is PartMgr and I am reluctant to delete upperfilters and lose that.

Also, lowerfilters at the same key may be involved too. According to what I have read, Acronis puts stuff there too. Mine only has drvmcdb which I think is normal.

Mine says:

PartMgr Snapman

I'll try blanking the text and leaving the key to see what happens. As a note, I did not have any extra drives pop up like LarryD and I don't have any LowerFilter key listed in this class. I'm sure that results will varry based on what people have installed.

I agree that in some cases it may be needed or is serving some function but it is definately linked to the crashes and getting rid of it stopped the BSOD for me.

If I have some time I'll play with it and report the results.


Restored the key and the BSODs came back instantly.

Blanked out the value for the key and everything seems to work OK. I'm not sure that this will fix LarryD's problem. Maybe instead of snapman he needs something else. But, for sure getting rid of the PartMgr Snapman solved my problems.

Good luck to you guys.

Maybe I didn't understand you but Snapman is the Acronis bit. When you double clicked upperfilters a window came up that listed both Snapman and PartMgr - right? Just right click on Snapman and you can delete just that value and leave PartMgr there.

Like I said, I may not have understood you but is that what you did? - delete the Snapman value and leave PartMgr there?


tried it both ways and PartMgr is the culprit. If I leave that one it crashes. Leaving Snapman was OK.

So PartMgr is the offending entry.
I had only PartMgr in my UpperFilters; no snapman. (I did have a remnant of snapman on my system, but deleted it earlier per the posting on the Acronis user forum.)

If I restore PartMgr to UpperFilters, then my hidden FAT drives disappear (as they should). Also, drive letters appear next to the Volume name in the Disk Management console. (They disappeared when PartMgr was removed.) But the BSOD comes back - same as for kam33mitch.
Anyone think the Discwizard/Max Blast/Acronis stuff could have modified or replaced "partman" native to windows? Any idea on how to check this? Hope we are getting close...
My partmgr.sys (in C:\Windows\System32\Drivers) says it's from Microsoft with a version of 5.1.2600.0. So I don't suspect any change here.
Agree...mine is same...partmgr.sys (in C:\Windows\System32\Drivers) says it's from Microsoft with a version of 5.1.2600.0

Have not had a chance to do a lot of research on this. It looks like PartMgr is a legacy driver.

It can affect systems by deleting it. On my other system, the drive letters changed after deleting it. No huge problem but just so you are aware you may have side effects.

Obviously the final solution to this is to get to the bottom of why PartMgr has such a "Disagreement" with the new clone. I think this will have to come from Acronis or Microsoft.
Not open for further replies.