Volume Shadow Copy Causing STOP 0x00000019 "Bad_Pool_Header"

By wildman6801 · 103 replies
Dec 19, 2007
  1. woodrow

    woodrow TS Rookie

    OK, my previous solution (updating the drivers for the storage volumes) didn't seem to work. Deleting the storage volumes and rebooting did the trick, though.
  2. dark green

    dark green TS Rookie

    The MBRfix routine above worked for me too (like everyone else).

    I found an article from a dev at ACronis that said the cause is that there are 4 bytes in the MBR that are supposed to be "unused" which defrag and Acronis both alter to provide information on when the drive was defragged and/or imaged. Unfortunately windows VSS uses those 4 bytes for something (nobody knew what) so it causes problems. Resetting the MBR altogether forces VSS to reinitialize and accept the new MBR.

    So we have Cause --> Effect --> Solution, I'd say the MBR fix should be pretty reliable.


    dark green
  3. compunerd

    compunerd TS Rookie

    Very Coincidental!

    YES! I have the same problem! I did a clone using Maxtor MaxBlast(Seagate/Acronis) about 2 months ago and I get the 0x00000019 BSOD when I try to use windows backup. I also have Seatools. Some one mentioned that was also a possible cause?
  4. tonylukac

    tonylukac TS Evangelist Posts: 1,372   +69

    If there are 4 "unused" bytes in the MBR, then why does uninstalling (I would say, the preferred method) the storage volumes work?
  5. compunerd

    compunerd TS Rookie


    I did the Mbrfix routine and now I just completed my first successful Windows backup off the cloned drive. I had Windows running in safe mode during the fix........no problems. Thanx Larry and Everyone else involved and thanx to techspot forums. I've been dealing with this issue for over 2 months!
  6. jschner

    jschner TS Rookie Posts: 16

    While MbrFix apparently does the trick (that's how I did it), the preferred solution seems to be the one whoppsrus suggested.

  7. Ralf_CT

    Ralf_CT TS Rookie

    More Acronis Problems

    Hi Wildman6801,

    I truly admire your efforts and patience.

    I cloned my IDE drive to a SATA drive last week. I tried Partition Magic 8, Ghost 12 and Genie Backup Manager Pro. v. 8. None left me with a booting SATA drive. Then a friend suggested Acronis True Image Home 11. I checked their site and due to the size chose to download Migrate Easy instead.

    The migration was easy, I was impressed. The cloning process took less than 30 minutes and I had a booting SATA drive. I even sent a letter of praise to Acronis. However, that's when my problems really started. GBM Pro. v. 8 was now no longer able to backup to my external USB IDE drive, nor my internal SATA drive. Always a BSOD and Bad_Pool_Header. EMC Retrospect 7.5 exhibited the same problem, each backup attempt left me with a BSOD and Bad_Pool_Header. That's when I downloaded Acronis True Image Home 11. This program allowed me to backup without any BSOD. I thought my problems were over. However, now, whenever I open Acronis True Image Home 11 my 'A' drive whirrs intermittently until I can't take it anymore and insert a stiffy.

    My question: if I format and re-install XP Home, and restore my entire 'C' drive from an Acronis backup, will I sit with the same problem? What about if I only restore the 'My Documents' folder from an Acronis backup?

    I find it unacceptable that Acronis have not made a fix available for this problem as their software has been proven to be the cause.

    One thing I can say for GBM Pro. v.8, their support is amazing. One is guaranteed a response within a day, or two. They really go out of their way to assist potential customers. Believe me, I've made full use of their services and they still treat me with a 'smile'. I think I'll revert to GBM Pro. once I've re-installed.
  8. jschner

    jschner TS Rookie Posts: 16

    Hey Ralf

    I don't understand why you don't try one of the "solutions" documented in this thread - either uninstall your storage volumes or run MbrFix ??

    Not sure what "Acronis backup" you are talking about but if you mean "Acronis clone" then that's what this thread is about - problems backing up after cloning to a new drive with Acronis and other similar utilities.
  9. Ralf_CT

    Ralf_CT TS Rookie

    Will try MBRFix

    Hi Jschner,

    I'm busy checking the first four pages of the post, had no idea this problem's been going on for so long. I've had no luck downloading MBRFix, will try again shortly. What about the similar Microsoft tool in Recovery Console?
  10. jschner

    jschner TS Rookie Posts: 16


    I have no idea about the Microsoft tool in recovery console.

    While I used MbrFix to fix my problem the preferred solution seems to be deleting your storage volume(s) and rebooting. See my post at 02-17-2008 10:06 AM which recaps this "solution."
  11. Ralf_CT

    Ralf_CT TS Rookie

    Deleted Storage Volumes

    Ok, I did as whoppsrus5254 suggested and scrolled to 'Storage Volumes' in Device Manager. One of the 'Generic Volume' labels had garbled text behind it. I proceeded and uninstalled this one, the others refused to uninstall. There was also a 'Serial' entry further up with an exclamation mark next to it. I uninstalled that as well.

    During the first reboot the three partitions on my 400GB USB drive were not visible, they did however return on the second reboot and the exclamation mark also disappeared.

    However, the 'A' drive still gets checked intermittently once Windows has booted, and my USB stick is no longer picked up (the light lights briefly, that's it) and Windows Explorer seems to freeze until I remove the stick.

    As I write this GBM Pro. v.8 is backing up, Retrospect 7.5 also backs up without incident. Thank you whoppsrus5254, I appreciate your help as hundreds of others do.
  12. dark green

    dark green TS Rookie

    This sort of thing is why I would actually consider MBRfix the "preferred solution" over trying to convince windows to uninstall a volume it is having trouble communicating with. Assuming the description I got from Acronis is correct (that the problem is caused by Acronis, Defrag, and similar tools making notations in a 4 byte area of the master boot record that windows is SUPPOSED to ignore), regenerating the master boot record seems like the cleanest solution.

    I might even hazard the suspicion that uninstalling the volumes and then trying to autodiscover them again may just be a roundabout way of regenerating the Master Boot Record. Anybody wanna record their MBR and then do the uninstall/reinstall storage volume trick and see if it changes? I'm not near a computer I can freely futz with.

    -Dark Green
  13. jschner

    jschner TS Rookie Posts: 16

    I suspect you are right Dark - that uninstalling the storage volume regenerates the master boot record.

    There are a couple of instances of feedback from the author of MbrFix in this thread and, while he didn't nix it, he didn't exactly inspire confidence in that approach either - made me a little nervous. So I still prefer uninstalling the storage volume to the MbrFix approach.
  14. David74

    David74 TS Rookie


    I bought 2 new seagate 160Gb SATA drives yesterday and not doing a cloning on any allready installed harddrive I proceeded to install windows xp from the CD and created a RAID 1.

    I allso got the BSOD stop 19. So the problem is not just when u clone or copy harddrive with windows on but also when you do a clean install.

    During the install the installation detected that there was allready a map that was labeled windows. The installation the proceeded with the question if i whanted to use this map and overinstall everything in it. I did so but maybe some of the softwhere that previous post have discribe where still present in that map. And maybe thats why I got the BSOD stop 19?

    I am going to try and get some help in erasing everything on those new harddrives and try again with a new installation.
  15. marse

    marse TS Rookie

    BSOD bad_pool_header, Acronis, Mozy

    I just wanted to thank the people on this forum who came up with the fix for this problem. I used the BartPE/fixMBR route and it worked perfectly. I am furious with Acronis and Microsoft (what's new?) for not being able to address this problem as effectively as the wonderful people on this forum. There is so much mis-information out there - thank God I decided to check this site.

    Wondering, though, if this problem is actually addressed after the clone. I can't remember but I'm thinking that perhaps Windows mentioned something about new hardware being installed and I might have ignored it. It might have been trying to rewrite the MBS right after I cloned the drive.

    If so, then it's my bad. I intend to talk to Acronis on Monday. I'll let you know.

    Again, my thanks.


    BACKGROUND DETAILS: Cloned fully functioning 18-month-old hard drive to avoid any future problems ahead of time. Installed new drive - worked fine. Tried to run Mozy two days later to update incremental backup, got BSOD. Solved problem with technique detailed on this forum.
  16. tgordo49

    tgordo49 TS Rookie

    Acronis vs. Mozy, BAD_POOL_HEADER stop error

    I had the same problem, and was glad to find this thread while searching for an answer! The problem did not show itself until my Mozy automatic backup started running. It looks like the solution whoppsrus5254 posted has worked, but I'm far from the point of having FULLY tested everything yet.
    What surprised me was that I did a long afternoon of on-line research before opting to go with Acronis for my XP migration, and read nothing about this potential pitfall, so hopefully bemoaning it on more message boards and blogs will push it up the list where others might be spared the misery of my frantic searching.
    Thanks to everyone for the great information on here!!!!

  17. templink

    templink TS Rookie

    thank you

    hello all,
    I don't usually post in boards, but took a minute to sign up to thank everyone for the solution to this problem. I had just bought a new 500 gb SATA drive to replace my 80 gb SATA drivea and used Seagate Discwizard for the clone, and subsequently the BSOD while using Mozy backup.

    I have been getting BSOD for the past week since drive replacement, and removing the generic volumes from storage drivers seems to have fixed it for now.

    thanks for sharing.
  18. imarpro

    imarpro TS Rookie

    Problem solved.

    The fix using Device Manager to uninstall and reinstall the storage volumes posted by whoppsrus5254 worked great! I started getting this error when trying to use MS Backup after cloning a drive using Apricorn's EZ Gig II. I've done several backups without problems since making the fix and have noticed no side effects. Thanks!
  19. ceril

    ceril TS Rookie

    Ive read this and many threads on the subject. I started to get this after my pc crashed and I had to use a cloned partition on my pc. it comes up all the time. I tried what you guys said. now my pc wont even boot. When i removed the hidden volumes it couldnt find the driver to reinstall them. I tried to then edit the registry and blank out the upper filters but not whe my pc restarts I get the BSOD. the only thing i havent tried it MBRfix but i have to figure out how to get to it, i can boot into a recovery console and use dos but i cant do much else. the system restore points are gone. last known good doesnt work. I might just have to format ad reinstall the O/S.. any suggestions?when i use do i can see everything on my pc so i think i just have to fix the mbr, maybe. I just dont know how to.thx
  20. ceril

    ceril TS Rookie

    n/m by playing w. mbrfix i managed to mess it up pretty good so im installing fresh. :-(
  21. jschner

    jschner TS Rookie Posts: 16

    I need to clone another hard drive and, before doing so, contacted Apricorn to see if the BSOD problem had been resolved. Here's what they said -

    "We actually did find a fix for the “bad pool header” issue. Before you get the BSOD you must go to device manager and then storage volumes. You want to uninstall all the storage volumes (if you can’t see them you might have to unhide them) and then restart the computer. When it reboots windows will reinstall those volumes and everything should work normally from then on."

    I haven't done it yet but we'll see.
  22. bernie28

    bernie28 TS Rookie

    This worked for me. I used Acronis True Image Home 11 from within Windows (WinXP SP2) to generate my image.

    I had to give a new signature - which I also did from within Windows (WinXP SP3).

    Strange, in my case, a Dell Latitude D630 laptop (transferred from a D620 hard drive) I seem to only have the BAD_POOL_HEADER problem when backing up while docked. Definitely linked it to the Volume Shadow feature, as not backing up open files would not break.
  23. tweaks_sav

    tweaks_sav TS Rookie Posts: 186

    I had the SAME exact issue about a week ago, this thread saved me. Lots of VERY detailed info in it.

    I cloned a HD using Aconis 11. Kept getting BSOD's only after the clone.
    Solution was to Right click the HD in Device Manager and Uninstall. Reboot. Fixed!
  24. Voltio

    Voltio TS Rookie

    Uninstalling volumes did the job!

    Hi everybody:
    Thanks for your job to provide a solution.
    Excuse my english, please. I arrived to this forum searching for a very strange BSOD Stop 19. You saved my life.
    I'll try to share my experience: BSOD Stop 19 running NovaBackup 10 with Volume Shadow Copy enabled to backup open files.
    The volume with WindowsXP was a cloned one from a smaller HD with Acronis True Image 11 and had four "Generic Volume and some strange symbols" when I checked Storage Volumes in Device Manager.
    I deleted all those entries and rebooted. Voilá! All my troubles gone.

    Thanks again
  25. LiaDip

    LiaDip TS Rookie

    I'd like to thank all of you for your fortitude in getting to a resolution to this problem. I've been chasing this problem since April and whoppsrus5254's simple solution did the trick.

    THANK YOU!!!

    Originally Posted by whoppsrus5254
    1. Go to windows Device Manager
    2. Click "view" and select "show hidden devices"
    3. Scroll down to "storage volumes"
    4. Click on the plus to expand.
    5. Click on each one listed and right click and uninstall. (you will get a message on some staying to reboot before it takes effect. Select no until
    you do them all.)
    6. Reboot.
    7. Wait till windows automatically reinstalls devices. Will prompt to reboot again.
    8 Reboot.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...