1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

WC2 BNE IPX issue

By Kittenz
Feb 7, 2010
  1. Me and my roommate were trying to lan Warcraft 2 Battle.net edition. My computer has no problem connecting to the ipx network, but my roommates won't allow him. He has all the same settings as me and we just can't figure it out. We've tried a few solutions we found online like changing the Internal Network Number to 00000000, Frame Type to Ethernet 802.3 and Network number to 00000001. Even unchecked NWLink NetBIOS. We're both running XP SP3 on a D-Link DI-604 Router. Getting frustrated because it was so simple on my machine yet for some reason we cannot get it to connect on his. I hope someone can help. I'd appreciate it greatly. Thank you
  2. rsrednam

    rsrednam TS Rookie

    Wc2 bne ipx

    hi, how many NICs does your friend have, physical and virtual?
    i have a few NICs...the LAN and a Hamachi (virtual) interface. i must only enable (checkmark) IPX in the properties for one of those NICs, or i experience problems. If i have IPX checkmarked on just 1 nic (LAN nic for IPX-over-LAN/GIT, or Hamachi nic for IPX-over-Hamachi) war2bne works just fine with my brother in California (using GIT or Hamachi.) it's been working fine for a year or so, after having to do a winxp tcp repair on my brother's comp after quake1 started misbehaving...all the other games still worked at that time, and after doing the tcp/ip repair, quake1 worked again. IPX is set up for internal 0, frame 802.3 and network 1, as you mentioned, and all IPX games we play work fine (war2bne, red alert 2, quake1, quake3)

    any luck yet? if you want a 3rd party to test with, i'm willing to help if i'm around (i live in Japan)
  3. seeds73

    seeds73 TS Rookie

    Having the exact same issue

    Hi rsrednam

    Trying to do the same in Australia to my brother.

    IPX installed on both XP mahcines and only ticked for Hamachi v1.0.1.5 interface

    Network#, frame type, etc.as above all set and double checked - can see game but can not join.

    I'm thinking its my brother's router. Any particular extra ports required? or are we already past that if we can see games but not join .... "waiting response"
  4. rsrednam

    rsrednam TS Rookie

    hmm. for my hamachi setup, there is a direct connection to my brother and sister. I don't have a specific port opened on my router. it's not a router-related issue, if you can see a game to join. once any hamachi traffic passes through the router, the router can generally be declared "good." i had the lobby issue for a long time with my brother over GIT. it cleared up.. my brother & i were messing with the XP IPX configs on both sides. then, at once, we switched the configs back to the standard, and the game worked. we'd done that before and it had not worked. So i'm not sure what happened that time. Some time later, it stopped working over GIT and we then switched to hamachi, with no problems at all.

    if you haven't, try upgrading hamachi (my client is v2.0.2.85 with driver v7.0.1.1), and do xp tcp repair on both machines. as well, i'll try to be around if you want to do testing.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...