WD Elements Desktop HD will not communicate with my laptop

By Alamshar · 10 replies
Aug 16, 2015
Post New Reply
  1. The problem started when it was brand new and I was transferring data to it. I got an error after about 20GB and it crashed.

    Now when I connect it I get the bleep sound from the laptop and it partially shows up in file explorer. By partially, I mean a drive letter is assigned but that's it - no other information. In addition, my laptop slows down to a crawl if I try to do any other operation.

    I cannot access the drive in any way from the laptop so scanning the disk with software repair programmes is not possible.

    Interestingly, when I connect it to my TV, I can view all the photos and videos on it and interact with them normally.

    The disk did not receive any post purchase knocks or bangs.

    I have done quite a bit of troubleshooting and I can be sure what the problem is not: It's not;

    1. The USB cable or port on my laptop

    2. My laptop or OS (tested on Windows 7, 10 and Vista on two pcs)

    3. Power issues to the drive

    4. A virus (I have no virus on my laptop and robust virus protection)

    It is under warranty but that is of no use to me. There is data on it that I don't have copies of and I need to get it off. Therefore non deletion of data has to be part of the solution.

    I have listened to it carefully and it does make a non-uniform humming sound but only in the first 30 seconds after start up after which it seems to run smoothly. To hear the sound I need to have it close to my ear and I can feel a small vibration with my hand about 3 times in the first 30 seconds Since I don't know.

    If this is the problem then I'd like to know what I'm looking to fix before I take it apart.

    I've been quoted €700 to have it repaired and they didn't even look at it!

    The only thing I want from it is to get the data off it. Then I can bring it back to the retailer to be replaced.

    Thanks in advance
  2. GeforcerFX

    GeforcerFX TS Evangelist Posts: 576   +186

    Try a ubuntu live cd, it it was working on your smart tv that's prob also using linux, so might be worth a shot on ubuntu.
  3. Alamshar

    Alamshar TS Rookie Topic Starter

    Well at least I learned something about Ubuntu but it hasn't worked. It failed to mount. I know that the dvd installed correctly as it successfully mounted another ext drive I have and all other programmes that I tried worked ok. Thanks anyway
  4. mrjgriffin

    mrjgriffin TS Addict Posts: 248   +110

    If you're connecting it through usb try going into your BIOS settings and seeing if your usb ports are set to "full speed" or "full utilization." that could help with the huge slowdowns but I doubt it will get the drive itself to mount properly on your laptop. if this drive used to be recognized just fine but after that 20 gig file transfer you mentioned was when it started messing up I'm just gonna take a stab in the dark and say it took a poop. one thing you may try is seeing if a certain setting in your bios changed. try setting your hdd setting from ide to ahci or from ahci to ide.
  5. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    I wouldn't do that. Even if the laptop BIOS has that option, that will likely cause your internal hard drive to fail to boot. Besides, AHCI vs IDE doesn't really apply to external hard drives that are connected via USB.

    Do you have access to another laptop or desktop to which you can temporarily copy files?
  6. Techpumpkin_WD

    Techpumpkin_WD TS Member

    Hi there,

    I'm sorry to hear that you are having such issues with your HDD. It's strange that it's working properly on a TV and not on a computer. Some TVs reformat the HDDs, but those won't normally be readable on Windows at all. It looks like Windows is having a hard time reading the partition table and this is what causes it to get stuck. You can try using a live Ubuntu CD and check if the drive will be accessible under Ubuntu so you can pull that data. Hope that helps.
  7. jobeard

    jobeard TS Ambassador Posts: 11,168   +986

  8. Alamshar

    Alamshar TS Rookie Topic Starter

    Thanks all but I've tried everything to no avail. The data I had wasn't worth €700 (minimum) and I was able to recover a lot of it from other places. So I decided to do some DIY and even opened to have a look at the arm placement on the disc. It didn't seem to sitting right but I'm not an expert. Knowing that I was likely to mess it up completely I tried adjusting it but completely messed it up. Without going into the details, the retailer wouldn't take it back. Consumer ProtectionLaw needs to be changed around this stuff. You buy a faulty HD, put data on it and it costs an arm and a leg to recover it and neither the retailer nor the manufacturer have any responsibility other than replacing the product - not good enough.
    BTW, I have found a way of getting a new HD out of the retailer. They got the broken one back and I got a 4TB one instead but they won't know it - revenge!!
  9. mrjgriffin

    mrjgriffin TS Addict Posts: 248   +110

    he can just go back into the bios and switch it back z.Z.z.Z.z
  10. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    But why do it in the first place when it won't do any good?
  11. mrjgriffin

    mrjgriffin TS Addict Posts: 248   +110

    Well I was only guessing to begin with. I wasn't sure if windows itself would label it as a sata device or not even if it was plugged into usb because I've never tried running a hard drive through usb. I figured if that were the case and the ahci/ide settings in the bios were different from the settings in the windows registry it may have caused issues. it was a huge shot in the dark I know.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...