1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Why does Windows not recognize me as an administrator after a clean Windows 7 install on a new HDD?

By Speck13 ยท 7 replies
Mar 29, 2014
Post New Reply
  1. I recently purchased a new 1TB WD drive for my Dell Studio XPS 435T/9000 PC. I installed Windows successfully onto the hard drive, and naturally became the administrator. In fact when I go to User Accounts in the Control Panel, it lists me as an administrator. But for whatever reason, when I try to do anything, I get "access is denied" error stating that an administrator needs to execute the command. What in the heck happened? Is there any way to take ownership of everything on my PC so Windows will recognize me as an admin? Is there another place to check user accounts in more detail other than the 'User Accounts' section in the Control Panel? I'll take all of the help I can get. I'm lost at this point.
  2. Jad Chaar

    Jad Chaar Elite Techno Geek Posts: 6,515   +974

    Can you take a screenshot of what comes up?
  3. TheBigFatClown

    TheBigFatClown TS Guru Posts: 669   +245

    You really should post just a few more details. What exactly is it that you have tried to do that triggers these "access is denied" messages? You say you installed Windows 7 fresh on a new 1TB WD drive. Okay, but are there any other slave drives hooked up to the same computer that weren't formatted? If so those files on those slave drives have owner permissions that could be left over from your last Windows 7 install.
  4. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Get the Control Panel
    • go to Administrative Tools
    • find Computer Management -> right click->runas Administrator (will require password)
    • look for Local Users & Groups (open it)
    • click on Groups -> Administrators
    • your login should be in the list (Administrator is always present)

    the name Administrators is a group(plural) while the singular is an ID.

    So, is your login in this group?
  5. gbhall

    gbhall TechSpot Chancellor Posts: 2,431   +77

    This can be intentional. If you are a member of the administrators group, you will still get prompted for 'permission' to do many things, such as install programs, run backups, defragment and so on. This requires true 'administration' permission. You can start such things with permission already with the right-click 'run as administrator' options.

    I vaguely remember setting up user access to force this to happen - for security reasons, but cant remember how I did it. This might help you understand http://windows.microsoft.com/en-gb/...tanding-user-account-control-in-windows-vista Win7 is nearly the same as Vista, but MS changed it to be less obtrusive.

    The other possible reasons, as another poster mentioned is because you reinstalled, you may still have data but have lost the user ownership.You can fix that too http://answers.microsoft.com/en-us/...rmission/d9b6c0d7-59e1-45dc-8a5e-1692cf1e86ca
  6. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    In the registry under
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-21-3496390126-4056983672-103562743-500
    the subkey ProfileImagePath points to C:\Users\Administrator

    The S-1-5-21-3496390126-4056983672-103562743-xxx is known as the SID
    and the SID for the Administrator login is S-1-5-21-3496390126-4056983672-103562743-500

    User logins we create, the SIDs are like
    (mine is -1000, my wife's -1004 and my self-created login ZZZ admin rights is -1001)

    SO, even though I login under ZZZ, it is easily detected that ZZZ != Administrator.

    So what? This has the implication that Administrator will match the NTFS Permisions for
    the Admin & the Admin Group, while ZZZ will only match under the Group permissions.

    Frankly, that the system prompts for a password is exactly the behavior I want to see as that means
    the only access is via the admin login.
  7. jobeard

    jobeard TS Ambassador Posts: 10,432   +801

    Oh, one more thought: You can find the SID of any user with the command prompt:

    wmic useraccount where name='username' get sid
  8. Anthony Prato

    Anthony Prato TS Rookie

    It says "remote admin" is my PC admin, did I get hacked?

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...