Winsock not connecting, Internet problem

By bornhackerx · 15 replies
Aug 2, 2010
Post New Reply
  1. Hello guys, Just signed up so I can fix this problem and help others out. So I am a pretty good Tech'y. I just bought this laptop off someone, and reinstalled Windows XP Professional.

    All was going well, except I cannot get on the internet, I have tried fixes, searching, cannot find anything that has worked. So I am coming here, hoping you guys can help me.


    -Here is a picture from what Diagnostic Center tells me.

    My internet shows Limited but no connectivity, and does not work.

    So does anyone have any ideas, or can you please help me. I have gotten it to connect at a hotel, so Im pretty sure its not the wireless card. Though if needed,
    Thanks alot.

    "'s are around links because my post count is not high enough.
    --Please simply copy whats inside the quotes and paste into a new tab.
  2. Sharam

    Sharam TS Rookie Posts: 509

    We expect more from Techy's, to the point that it does not leave any questions ;)

    Welcome to the TECHSPOT Forums!

    Is this just an issue with the built-in Wi-Fi and not the Ethernet? Have you checked the card and antenna wires visually?

    Since you are a Techy, can we assume you started off with checking for BIOS updates, installed XP with SP3 integrated, installed the chipset drivers and performed all POST SP3 updates including any drivers, patches and fixes from the manufacturer?

    Have you tried LSP-FIX?

    What is the make and model of the Laptop?
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Tell us more about LSP-FIX... what it does and where it is found
  4. bornhackerx

    bornhackerx TS Rookie Topic Starter

    Well, I have used my brothers wireless adapter an it worked, Yes I installed all BIOS UPDATES, and installed all the latest drivers for my Toshiba. Its an Toshiba Satellite A105-S1712. I also tried LSP-FIX yes. I also took out the wirelesscard and put it back in, I don't think theres a problem with it.
    Anything else I should try?
  5. Sharam

    Sharam TS Rookie Posts: 509

    Are you using Windows WZC (Wireless Zero Configuration) or the Atheros utility? Have you tried both?

    Apparently the Atheros A5005G has some issues with some routers! (no personal experience just searches) what router are you having this issue with?
  6. Sharam

    Sharam TS Rookie Posts: 509

    raybay, LSP-Fix is supposed to repair Winsock 2 settings as per the tiltle and the Networking Diagnostics report bornhackerx provided a picture of, but you would expect to get errors with a faulty Connection.

    More info available here:
  7. jobeard

    jobeard TS Ambassador Posts: 11,138   +985

    the basics of an ethernet connection are described here

    ipconfig /all documents your current settings

    If you can PING using an ip-address ( say google's address of,
    then you have basic TCP-IP connectivity.

    However, that is insufficient to make your email and browser operate - -
    they both need to resolve (or translate if you will) a name into that ip address
    which is the function of DNS.

    One of the subtile issues is the autoconfig getting your LAN address and the DNS
    server addresses, which is done on ports 67&68. Depending upon which firewall you are using,
    you may need to Allow In/Out UDP ports 67-68 (to or from ip address=any)
  8. bornhackerx

    bornhackerx TS Rookie Topic Starter

    Im reading what you wrote and don't get what your telling me to do, could you be a bit more clear on what I could do?
  9. bornhackerx

    bornhackerx TS Rookie Topic Starter

    Btw, I have a Linskys router.
  10. Sharam

    Sharam TS Rookie Posts: 509

    The only similar problem I've had was with ThinkPad T42, if I used the recovery partition to do a factory default, everything worked with no problems, if I did fresh install and applied the latest drivers and all, I had connectivity issues with the Wireless adapter. I don't know exactly what I did but I know that I tried different drivers and it worked.

    I sold many of these refurbished T42s, problem was only with 2 of them and XP, Win7 no problems at all. So, the only thing I can recommend is to uninstall the driver and try an older or another one.

    There is an unofficial Atheros site with drivers dated Aug 1, 2010 but I don't trust the site, I believe it ends with .CZ, never been there before but tried the Download button and it kept re-directing, the "all in one" INF however, I could copy and paste in to Notepad, you might want to try that with caution if all else failed.

    If you can get you hands on another Mini PCI card, give that a try, shame, I have 2 sitting here collecting dust, a Broadcom and an Intel!
  11. Sharam

    Sharam TS Rookie Posts: 509

    Great wite up jobeard, thanks for the time and sharing, if you don't mind I will use it as reference.
  12. bornhackerx

    bornhackerx TS Rookie Topic Starter

    Would be great if you could get me that website, unless its my Router which could be a good probability. But I will try different drivers, I just ordered a new Battery for this Laptop, and a new keyboard. Im investing alot into it, would like to get this working :D
  13. Sharam

    Sharam TS Rookie Posts: 509

    Try and find A5005G (I only see AR5005G) click on the XP 32 bit and in the next page clcik on the "32bit INF file from Atheros AR5005G driver version" copy everything from ;/*++ to the end, paste in to Notepad and call it Atheros.inf.

    The download does nothing for me and I don't recommend it.

    EDIT: I don't think it is your Router rather the way the drivers mediate between the two.
  14. bornhackerx

    bornhackerx TS Rookie Topic Starter

    Well, after trying everything, I have came to the reasonabale conclusion that atheros, and my router are not fit for eachother. I went on a website, found a working Wifi Adapter/With antenna for 11$ USD. Thanks for all your help guys, but it just didn't help. I will stick around on this forum.
  15. Sharam

    Sharam TS Rookie Posts: 509

    Sorry to hear.

    If you were close I would've sent you one my now 3 Mini PCI cards.

    See you around.

    EDIT: You mentioned ordering a new battery, just wanted to make sure you applied the BIOS update that resolves some battery issues!

  16. bornhackerx

    bornhackerx TS Rookie Topic Starter

    Yup, Flashed the bios, Its good to go :D
    Thanks for asking.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...