Wireless USB adapter isn't picking up my network

By swayyy
Dec 6, 2012
Post New Reply
  1. Hi All,

    Recently my roommate moved out and I had to get my own internet service. Prior to the change my D-Link DWA-125 was working fine. After the change I can see the network; however, I couldn't connect. I decided to re-installed the driver and now it's not picking up any network. All other wireless devices are connected. So it's not the signal. The driver is updated.

    Also I tried installing another wireless usb adapter and it's the same result. While installing the driver I would get a message saying I aborted the installation and the adapter can not be found. I can see it in the "device manager". Could it be a firewall or virus program preventing it?

    Your help will be much appreciated. Thanks in advance.
  2. remixedcat

    remixedcat TS Rookie

    Please uninstall all the drivers and if they don't successfully uninstall all the way I recommend you downloading something called Driver Fusion from the following site: http://treexy.com/products/driver-fusion

    and it will completely wipe all traces of the wireless adapters and then you will need to re-install the latest versions of the adapter drivers and see if that helps.
  3. jobeard

    jobeard TS Ambassador Posts: 11,165   +986

    Where did you get the driver, from the PC support site or elsewhere?
    To use the MS driver, click on the device and get the properties; update from there
    Firewall controls access, not installs. The MS Install service will stop if nothing to do, so it must be set to AUTOSTART

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...