XP refuses to boot up after installing new SATA drive

By Manar ยท 7 replies
Sep 3, 2008
  1. I have a annoying problem.
    Recently i bought a new drive, a Seagate Barracuda 7200.10 1TB / SATA / 7200rpm and a SATA card, a VScom Serial ATA-150 PCI Controller.
    After inserting and installing the card i plugged in the drive and started up.

    After the quick BIOS check it said

    Sil 3112A SATARaid BIOS version 4.2.12
    Copyright(c) 1997-2003 Silicon image, inc
    Press <Ctrl-S> or F4 to enter RAID utility

    Primary Channel ST31000340AS

    and then it froze.

    If i disconnect the drive then everything works fine and just say

    Primary channel: Drive not found
    Secondary channel: Drive not found

    but with the new HD it always freeze.
    Also, with the drive connected i cannot access setup in BIOS.
    It register that i have pressed the buttton, but then it continues to the page i just mentioned and freezes.
    Pressing F4 or Ctrl-S does nothing either.

    Anyone knows what can be wrong ?

    My computer is a Dell 2400. and my tech skills are minimal ;-)
  2. raybay

    raybay TS Evangelist Posts: 7,241   +10

    The Dell 2400 does not normally use a SATA drive. It is designed for EIDE/PATA drives.
    So I suspect your SATA card is not properly installed. Did you get a Serial ATA controller install disk?
    Either your controller is not properly prepared, or the hard drive is not yet setup with the Seagate Seatools disk that should have arrived with the drive.
    Tell us more.
  3. Manar

    Manar TS Rookie Topic Starter

    I got a card called Vscom Serial ATA -150 PCI controller
    I installed it before i tried the HD and Windows say it works fine.

    There also followed a disc but i have not installed it yet. According to the instruction i should plug in the HD first.
    Shoud i install the disc and then plug in the HD ?
  4. raybay

    raybay TS Evangelist Posts: 7,241   +10

    My guess is that you need that disc to install that hard drive... Install the hard drive, then boot to the disk to configure it.
  5. Manar

    Manar TS Rookie Topic Starter

    I installed and run every program from that cd, and i also tried to use it as a boot disc. No change. The boot still freeze when it shows the channels :(
  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

  7. Manar

    Manar TS Rookie Topic Starter

    Thanks for the link! They suggest that something is wrong with the BIOS for the SATA controller card. I tried to flash it to the latest version but cannot get it to work. THe only programs i found that could flash an add-in controller like mine was siflashtool and UPD flash. But siflashtool failed to detect any Silicon Image Storage controllers on my system, and UPD flash require that you use a floppy to reboot the system with. My system has no floppy drive. :(

    Anyone know any other way to fix this assumed fauly BIOS ?
  8. Manar

    Manar TS Rookie Topic Starter

    I finaly took my machine back to the shop. They tested it and in the end found out that the SATA card i had was uncompatible with Dells idea of a computer. I got another model and now it works.
    Thanks for all help though.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...