1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice / DHCP problem?

By PCEndUser ยท 6 replies
Nov 23, 2009
  1. Hello. I am using a laptop pc/windows xp. Today, I tried to connect wirelessly to my modem. The program I use (Intel ProSet/Wireless) says I am connected to my profile but I still have no access. The IP address listed is When I try to repair the connection, I receive a message that Intel ProSet/Wireless was unable to repair your connection. I called my cable internet provider thinking it might be the connection and they said it was my network card that was causing the problem. Is there a way to see if this is a software issue or a hardware one? Thank you!
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    An IP address of essentially means your wireless card isn't getting an IP address from your wireless router (so yea, some DHCP problem) (and the issue is between router/laptop adapter. Your ISP isn't involved)

    1. Make sure your wireless adapter is in fact trying to connect to YOUR wireless router (vs. someone else's it found)
    2. You can always run wired till you get it figured out
    3. Manually reconfig your wireless SSID and encryption key and possibly reset the router
    4. you might also uninstall / reinstall the network wireless driver so it sets everything back to defaults (then reconfig it yourself from that point)
  3. PCEndUser

    PCEndUser TS Rookie Topic Starter

    Thank you. I verified I was connecting to my own router. I've had the same profile for years but I did the steps you mentioned to make sure. I have tried to uninstall the driver for the Intel ProSet but I keep getting "not responidng". I will continue to try.

    I also got a new symptom. The program I use to connect to the internet via my profile now says "No supported wireless adapters available in the system". Before that popped up I was getting an IP address of all zeros and still saying connected. Hope this is clear. Very very end user. Thank you for your patience.

  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +183

    1. You might also power cycle the router and then try again to connect to it
    2. I'd expect the "No wireless adapter" message to appear when the driver was uninstalled. If you look at Network Connections (e.g. via Control Panel if you're running XP) it should display a wireless adapter when it exists
    3. Have you tried manually connecting to the wireless. When you're wireless manager displays the different networks it finds, click to Connect. Does it prompt you for the network password? Try entering it manually if you can
    4. If you can't make any progress you might want to find the RESET button on the router (which restores it to factory defaults). This would unencrypt the wireless and reset the settings so you can try to see if you can connect to the unencrypted signal
  5. PCEndUser

    PCEndUser TS Rookie Topic Starter

    Hi. 1. Tried to power cycle. Same problem.
    2. Was getting this error even before I tried to delete driver. Still have had no luck deleting. Still freezing when I click uninstall.
    3. Have been manually entering password.
    4. Reset didn't change anything, unfortunately.

    Btw, I recently started using an xbox wireless adapter. Could that cause this problem? A conflict perhaps? Or maybe the network adapter is just faulty?

  6. nickc

    nickc TechSpot Paladin Posts: 923   +11

    Do u have another adapter u could use? anything mechanical can not be good.
  7. PCEndUser

    PCEndUser TS Rookie Topic Starter

    thank you!

    I have no idea how this worked (or maybe the problem just resolved itself during the many trials) but I switch from using ProSet to using Windows ands and suddenly, I got the right ip address. No idea what really did the trick but the connection is fine now.

    Unfortunately, a new problem developed. Now my computer is making a ticking noise--like the one that is made when a key is stuck--and then freezes up. I wobbled each key to make sure it isn't in fact a stuck key. I am left no choice but to power down with the power button. When the computer reboots, the noise is gone and everything is back to normal. It has happened twice in the last hour. Any ideas? Going to post this as a separate post too to see if anyone has seen this. Thanks again for the help!!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...