7zip compression fail; 'access is denied'

By enderlicious · 4 replies
Nov 11, 2012
Post New Reply
  1. I moved a bunch of files off of my main computer, onto an external drive. But after doing that (and doing some rough spot-checking that the files work after copying) I'm also making zip archives, so when I have to move from external to external drive it won't take as long, and I won't have to worry about individual file copying fails....

    While trying to compress some of those folders (other folders created the same way work just fine) 7zip gives me a diagnostic error: "WARNING: Access is denied." with some box after that?

    I've looked online, and the only suggestion I saw was to change the ownership of the directory (I'm running XP), so I followed instructions to do that, and it appeared that that worked. Deleted the old zip archive, and tried re-compressing... and I get the same error.

    So, is there some way to figure out why 'access is denied'? What should I be looking at, to try and figure out how to fix?

    Attached Files:

  2. jobeard

    jobeard TS Ambassador Posts: 11,123   +982

    1. precisely how did the file get to the J: drive?
    2. and what was the original source location of the \Web_2012-06-13?
    3. what user owned that folder?
  3. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    1) Opened My Computer, opened J: (and directories). Opened My Computer, opened F: Grabbed it with the mouse, dragged it over.
    2) F:\Web_2012-06-13
    3) Same user
  4. enderlicious

    enderlicious TS Rookie Topic Starter Posts: 55

    I found one specific file which is causing me problems (there may be more, will look soon), and found this link:


    I'm administrator. I've turned off simple file sharing, and done everything in the article - but it doesn't actually change anything. The file won't change permissions for some of my groups, since that's inherited from the folder. I did add a new group called administrator (vs. administrators) and gave it full control (all other groups have full control as well). Which did not help either.

    And, more precisely I'm running XP Pro on x86

    And, more specifically - the file will not allow me to open it (it's an html file) in the browser, nor as a text document (wordpad), as well as causing 7zip to bail with an error.

    It will, however, let me move the directory it's housed in (I buried it a level deeper to aid me when I was plugging in individual files into 7zip to figure out which file was causing me problems).
  5. jobeard

    jobeard TS Ambassador Posts: 11,123   +982

    the article is here and I suggest you read it all VERY slowly.
    btw: it was a mistake to " I did add a new group called administrator (vs. administrators)".
    • There is a user ADMINISTRATOR, which is hidden on the /Home editions of windows but visible on on /Pro AND
    • there is the group ADMINISTRATORS which will automatically contain all logins which are not LIMITED.
    You only made this more complicated.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...