8-in-1 Mem Card Reader Dissapears from Device List at Times

By Obi-Wan Jerkobi
Apr 20, 2008
  1. This is more of a question as it is just kind of annoying at times but I would like to know why and maybe how to fix this...

    Trying the good post logic...

    What Happens

    Sometimes, whenever I insert a card into the internal memory card reader, it seems like it shorts out the reader and causes it to disappear from the device list. Oddly, the built-in USB port still works but the reader doesn't and I may sometimes have to reboot the PC for it to start working again. This happens at random times.

    Important Specs of What is plugged in.

    Plugged Into: ASUS M2A-VM Socket AM2 uATX Motherboard

    What's Usually Plugged Into It: Fujifilm 1GB xD card, Bamboo Touch Pad (USB)

    What I have Tried

    I try to ground myself before putting a card in. That doesn't help. I have even spent a day at the pc with an anti-static wrist strap on and connected to the case. I've tried an external card reader and that doesn't happen to the external one. I do not have another pc capable of using the internal reader.

    How long this has been going on

    About a month.
  2. simonjester

    simonjester TS Rookie

    I doubt the anti-static wristband is helping much, but it doesnt hurt. Have you tried cleaning the port you're having issues with? Sometimes dust and dirt builds up and causes the contacts to... not connect anymore. Use one of those compressed air cans you can buy at Staples, or just blow in there with your mouth and see if anything comes loose, then try again. Cleaning with IPA would be ideal but normally these ports are too small to get anything small enough in there
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...