A bad SSD, a bad port, or a bad cable?

Wottzy

TS Rookie
Hi everyone,
So here is my longer story, I feel that I have to tell it in details, as it will help tell what the problem is.
I recently bought an SSD from Aliexpress, for a pretty cheap price, it had a lot of good reviews, like 4.9/5.
The name is Goldenfir 1 TB ssd.
My motherboard has 4 SATA ports in total, 2 of them are SATA 3, and the other 2 are SATA 2.
I've plugged the SSD in SATA 1 port and left my 7200k rpm 1TB HDD on SATA 0.
The first time I installed it everything worked fine, I installed a windows 10 64 bit on it, made 2 partitions (120GB and around 800GB), until a week later I started having a terrible lag while moving with my mouse on the desktop screen (with all apps off). I just restarted the pc and it started repairing the drive C (my windows drive), after which it was fine, I could play any game and noticed no fps difference, or some lag spikes.
2 days later I decided to install Malwarebytes, tried to do a full scan, and ended up having a blue screen every single time.
I searched for some benchmark or just monitoring/testing software and found HDDscan to have an option to test your whole drive (the read and butterfly read tests).
I did the butterfly test, and it finished with no problems, in fact the speed of 99.9% blocks was read at <10ms.
I started the READ test, it reaches 27% and the grid starts filling with "BAD" blocks, and the pc restarts again on itself.
It's worth it to mention that after each restart the device was not recognized as a bootable device in the BIOS, so I had to turn off the PC and turn it on, which seemed to do the trick.
I formatted the SSD, I installed a clean, fresh copy of windows 10 (64 bit), plugged it in port 0, while the HDD was in port 1, did the same READ test, and it went really good, there were no problems.
Installed a few games, been using it for 2-3 days, when today in the middle of playing Witcher 3, my screen got stuck, and it wouldn't react to anything I press, so I restarted the pc, and the same problem again - the ssd was not recognized as a bootable device. I unplugged it from the mb, and plugged it again in the same spot, and for some reason that seemed to work.
Out of curiosity I though what if there is something wrong with the motherboard, so I plugged it into port 1, meanwhile disconnecting the HDD completely, and this time the device was recognized, but windows would never start on it, no matter how hard I would wait, while the HDD seemed to work fine on port 1.
I've disconnected the HDD completely, plugged the SSD in SATA 3 port 0, did the HDDscan READ test, and I get this graph every time, where there are 2 giant down-spikes.
My question is, is there something wrong with the ssd, or is there a possibility that the SATA 3 ports get overloaded with 2 things plugged there?
Or maybe both SATA 3 ports are bad?
Really sorry for the enormously long post, I have a few more days to ask for a refund.
Thank you in advance!
chart.jpg2.png