A strange USB Flashdrive situation

By GlobalTrucker ยท 6 replies
Jan 9, 2010
  1. Hello,

    I have read both the advice by Tedster and loads of other stuff both here and elsewhere on the net. However, nothing seems to match.

    My USB Mass Storage stick has been working fine for a while. Contrary to much advice given about removing these devices I have allways just pulled it straight out and stuck it in elsewhere. It has worked consistently on all sorts of systems from XP through VISTA and WIN7.

    and then....

    I was using it on my XP machine and just for a laugh I thought I would use the 'Safely Remove Hardware' button. And now the device is removed...permanently.

    When I insert it the light doesn't come, it is not recognised, no drive letter of any kind is allocated, it doesn't appear in any lists, and so on, on all machines I can possible find.

    Some of the data is backed up but some isn't.

    I suspect that either: I am doing something silly and everything can be fixed; the stick is completely dead and I shall have to put it down to experience.

    I hope that the first is true and someone can give me some quick advice about how to fix it

    many thanks,
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    For your immediate problem see this post for [post=727106]How to use the DriveCleanupTool[/post]

    As to using/not using "Safely Remove". Using "Safely Remove" notifies Windows that you want to remove the device
    > Windows can then be sure to write everything it needs to the flash drive and close any open files before you remove it

    When you "unexpectedly" remove the drive.. it's "luck of the draw". Yea, most times it happens it won't be harmful but sometimes it can end up corrupt the flash drive filesystem and you may lose your data (and hope data recovery tools can find it)
  3. GlobalTrucker

    GlobalTrucker TS Rookie Topic Starter

    Still no juice!

    The utility removed about a trillion USB devices from my XP machine but it hasn't solved the core problem.

    The stick still shows no light and doesn't go 'bing' when I insert it. Neither this nor any other machine seams to pick it up in any way at all.

    Any further suggestions are welcome.
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    As it's failing an all machines... sounds like the flashdrive is dead :dead:
  5. GlobalTrucker

    GlobalTrucker TS Rookie Topic Starter

    Learning to live with the loss...

    You may be right. It just ironic that the one time I use the 'Safely Remove' option is the time it chooses to die, stupid coincidence!

    Furthermore, I am amazed at how suddenly it happened. I was kind of expecting it to start getting temperamental and start giving intermittent access and read/write problems before going south. Its just so amazing that it was working at 100% on all kinds of machines at all times and then went completely belly up all at once. It suffered no catastrophic events and wasn't abused in any way.

    It did have a high work load with lots of read/writing every day but that was it. I loaded some stuff onto it on one machine 'removed it' and when I plugged it into the next machine ten seconds later it was dead. Thats really quite scary....
  6. Joe Walton

    Joe Walton TS Rookie Posts: 36

    I am exactly the same i pull my pen drives / usb hdds out without using safetly remove, but aslong as everything has finished copying to it.. that wont cause a problem. In your case I dont think its the fact that you used "safetly remove" like you say I think its just random that its happened now and it sounds like its dead.

    I had a similar problem recently and holding the pen drive up a bit or down or either side would make it connect (whilst i backed up) but then letting go it would disconnect. Could be a similar problem, worth a try anyway

    Cheers Joe
  7. ekul9luke

    ekul9luke TS Rookie

    at school i saved a document from a mac on word to my flashdrive. now im at my house and im on a dell pc and wen i try to upload the document onto my pc it says the characters are unreadable, i think the formatting is different. can anyone help?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...