1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Access denied to backup restore

By siddharthparmar ยท 5 replies
Aug 13, 2009
  1. i have a windows vista home basic in a compaq presario notebook
    i made a backup using the recovery manager and formatted using the recovery to get the factory conditions. now i have restored the backup of about 60gb made on an external hard disk.
    but now it shows access denied when i try to open any file that has been restored.
    The files are stored in a folder (system recovery files) in the c: drive.
    i have copied one of the files to desktop but it shows access denied when i try to open that file.
    all the files of format .jpg , .mp3 , .txt etc are not opening
    please come up with a good solution asap

    i am in urgent need of the files
  2. captaincranky

    captaincranky TechSpot Addict Posts: 14,593   +3,760

    I have no idea. This seems to be a theme recently where nobody's back-up program will allow them to access the files.

    The only two ideas I can come up with are 1, you should re-post this in the "Windows" forum. And 2, get with support of the external drive manufacturer. There may be encryption of file involved when writing to the external drive .

    I'm sorry I'd don't have more than that for you.
  3. jobeard

    jobeard TS Ambassador Posts: 12,663   +1,474

    when you reformatted, you lost the CSLID of the original users.

    The new install gave you new ones for every user.

    When the recovery completed, the NTFS permissions were those of the ORIGINAL users and thus the new users have no access.

    Login using an ADMIN id.
    • find the highest level directory which has the problem of access.
    • backup to the point of locating the parent directory; (vista) \users\loginid\ (XP) \documents and settings\loginid\
    • now change the NTFS permissions to allow $newuserName$ to have Full Control
    Right-Click on that directory->Properties
    click the Security Tab
    in the top half, under the list of Group or User Names, click add
    in the Select Users or Groups, enter the newusername and click check name
    click ok​
    that user name should be highlited so in the lower half
    [x] full control
    click Apply​
    allow all child files/directorys to be updated
  4. siddharthparmar

    siddharthparmar TS Rookie Topic Starter


    hey thanks for ur suggestions
    i just changed the user name to the one i had before formatting
    and restarted the computer and then copied the files to my desktop and they did open.
    thank u all
  5. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,430   +186

    I'm sure just a typo.. but if i may provide a technical clarification for us geeks :)

    SID vs CLSID

    I think you meant SID (Security Identifier) which Windows generates one per userid vs
    CSLID (Class Identifier) which Windows generates to identify COM objects (e.g. application programs)
  6. jobeard

    jobeard TS Ambassador Posts: 12,663   +1,474

    typo? more like a mind meltdown --- GRRR -- of course SID :) THANKS!
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...