ActiveX plugins freezing IE

By KingCD ยท 17 replies
Feb 11, 2007
  1. Hey everyone, I'm new here, and I'm not even sure if this was already answered (did a quick scan through search results). I am attempting to play a game to pass the time with a bunch of friends of mine called Gunbound. They have all managed to get it working, and yet, when I try to install the ActiveX plugin, IE just freezes on me. I would try using a different browser, but IE is the only supported one by this website.

    On a hunch to try and fix it, I ran Ad-aware (just to clean out anything, which got rid of several data miners) and tried installing the new version of IE. On both versions I tried setting unsigned ActiveX controls from "disable" to "prompt," although that didn't do anything either (figured I might as well try). When IE 7 was finished installing and told me to go to Windows Update to finish getting whatever it couldn't install, I headed there and tried to install the ActiveX plugin on their website, which proceeded froze IE again. If anyone has any tips on how to go about trying to fix this, I'd really appreciate it. Thanks!

  2. Goalie

    Goalie TS Booster Posts: 613

    Two things to suggest: First, try downloading and installing the most recent version of Windows Script Host from Microsoft. I believe they're up to version 5.6. WSH controls the jscript and vbscript.dll's that are often used in ActiveX components. WSH is here:

    When it asks you to validate, be sure you use the .exe route instead of the control route- else you'll freeze yourself!

    Also, I would check your installation of Macromedia Flash. Many games launch a MM Flash object from an ActiveX object.

    If you look in your System or Application logs around the times of your using IE or freezing, do you see any pattern to errors? Or are there any other regular errors???

    Look forward to hearing back.. Sorry it took so long to respond.

    And by the way- Welcome to Techspot!!
  3. KingCD

    KingCD TS Rookie Topic Starter

    I tried downloading the newest WSH version (turns out the check program wasn't able to simply run from Firefox, so I saved it and used it to continue). No luck there. About to download the newest version of Macromedia (if I don't have it already), I'll edit this as soon as I get it installed and try it. As for the logs, I'm not sure I know exactly how to access them. I know some basic computer repair stuff, but that was only a semester long, unfortunately.

    And no worries about the delay. Luckily, this is not a major problem, and I normally use Firefox anyway so this doesn't exactly hinder my regular activities, just from playing this game.

    Thanks for the welcome! :)

    Nothing on reinstalling Flash, either. At least, the site told me it had been successfully installed without prompting me to allow access or anything first. Last time I had control before that was just pressing "install now" and being redirected. I installed it with IE, also, since it seemed to have two totally different files depending on whether you were using Firefox or IE.

    In addition, the past three times that it's crashed I copied the "technical details section" that includes what files would be sent to Microsoft with the error report. Just let me know if you need it.
  4. mikescorpio81

    mikescorpio81 TS Rookie Posts: 292

    Do you play this game through a web browser? If so, try trusting the website in TOOLS - INTERNET OPTIONS - SECURITY - TRUSTED SITES - SITES (when you add the site, make sure you un-tick the require https checkbox).

    Try this first and if no luck, let us know and we'll go from there.
    Also, could you post the weblink to the site?

    Cheers :grinthumb
  5. zipperman

    zipperman TS Rookie Posts: 1,168   +7

  6. KingCD

    KingCD TS Rookie Topic Starter

    The ActiveX test on PCPitStop simply froze IE like every other plugin that asks for permission to run.

    Trusting the site at least got some movement; the little icon next to the IE tab is spinning and the buttons do light up when I hover over them, so it's not a complete loss. Still waiting to see if anything else happens or it's just gonna do that all day, even though it's been at it for a good solid minute or two now.

    As for the website:

    By the way, I had a friend stop by and take a look at my computer real quick to see if he could figure anything out...he believes ActiveX could be corrupted (hence why even Windows Update crashes it).

    Thanks again for all of the help, :)
  7. mikescorpio81

    mikescorpio81 TS Rookie Posts: 292

    Did the page end up loading or are you still at square 1?

    You could also try the following:


    Go through and see if any are set to disabled
  8. KingCD

    KingCD TS Rookie Topic Starter

    Still at square one, nothing wound up loading, and I couldn't do anything except force quit it.

    Nothing under any of the four menu options on "manage add-ons" is disabled.
  9. zipperman

    zipperman TS Rookie Posts: 1,168   +7

    pcpitstop ?

    They are usually good at solveing this.Did you see the time and date as they
    described ? That means Active X is OK.
    If not you should have seen some advice on activateing it.
    Thats how i fixed mine.
    Try doing All Tests.See how many checkered flags you get and advice for
    the others.They keep me fine tuned for years now so be patient and don't move the mouse unless you have to during tests.
    shut down popup stopper and what else they advise.
  10. KingCD

    KingCD TS Rookie Topic Starter

    No date and time. The browser wasn't responding. All tests froze it too. I tried turning off the popup blocker before and after trying to install the control for the tests and for the ActiveX test, and IE froze every time regardless.

    The advice that would pertain to me according to their list before I allowed the ActiveX control to install:

    If you see the message ActiveX is not supported, then your browser doesn't recognize ActiveX at all. Netscape, Opera, or other browsers usually do not support ActiveX.

    Once I try to install the control, IE freezes. And yes, I've been using IE the whole time that you guys all suggested potential solutions, in case you're wondering.
  11. zipperman

    zipperman TS Rookie Posts: 1,168   +7

    My IEx settings.

    Are your the same. ?
    I am useing IEx 7.0.Good Update.
  12. KingCD

    KingCD TS Rookie Topic Starter

    The only difference is the ActiveX option there is set to "disable"...that should just mean that it would prompt me, though, right?
  13. zipperman

    zipperman TS Rookie Posts: 1,168   +7

    My settings

    This was the best i can do since i don't have your problem with these settings when i upgraded to IEx7.
    You might be setting your security too high.
    Try setting your INet options to default.
    Best i can add,except pcpitstop fixed my Active X .
    So i posted mine,you decide.
    You say you dont see that option when you first start tests ?
  14. zipperman

    zipperman TS Rookie Posts: 1,168   +7

    1 more ?

    Did you not see what i attached ?
    Did you Read the blue option.
  15. Skizzy

    Skizzy TS Rookie

    Any solutions to this? I'm having the same problem and have tried all the suggestions in this thread.
  16. Skizzy

    Skizzy TS Rookie

    No one knows?
  17. Lolo1987

    Lolo1987 TS Rookie

    I am having this exact same problem. Can't figure out how to fix it.
  18. zipperman

    zipperman TS Rookie Posts: 1,168   +7

    Lets start over with KingCD

    First,posts of me too are not allowed.
    I havn't understood in any way,what the problem is.
    Downloading these programs should not be a problem,unless you make it one
    with your browser settings.What Browser is it ?
    Use IExplorer till you get these installed.
    Did you do the Active X check ?
    I have both of these installed BTW.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...