Administrative Priviledges on XP

By mukulika ยท 14 replies
Oct 11, 2009
  1. I'm on Windows XP. Every time I try to make a change from msconfig, I get an error message
    "An Access Denied error was returned while attempting to change a service. You may need to log on using an Administrator account to make the specified changes". However, I'm then asked to reboot my system, and generally the changes get done, barring NvCpl which I can't disable from start-up using msconfig. I am the only user and Administrator on my computer.

    I was suggested Ratscheddar but it's presently not available, after Castlecops closed doors.

    Also, when I open up "My Computer", it shows a 3 1/2 Floppy [A:] drive, which really should not be there because I do not have a floppy drive on my computer. How can I get rid of it?

    It'd be great if someone could help me out. Thanks a lot.
  2. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Re: msconfig / Access Denied

    This is most often the result of an HP Windows service: Pml Driver HPZ12
    • It normally has Startup Type= Automatic
    • For whatever reason, it's Startup Type can not be changed from msconfig or windows services tool (e.g. click Start->Run, enter services.msc. Find the service. Try to change it;s startup type and you always get an error message)
    • The startup type CAN be disabled using the registry (if you're familiar with the tool)
      > Start->Run, enter regedit
      > Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Pml Driver HPZ12
      > Rt click on Start and modify its value from 2 to 4
      > Close regedit and reboot your computer. No more msconfig access denied msgs
    • HOWEVER, according to HP while this service doesn't affect most printer functions you should set back to Automatic if you have printer problems
    Or, simply live with it the way it is (I have the same issue and that's what i do ;) )
  3. mukulika

    mukulika TS Rookie Topic Starter Posts: 53

    Thanks a lot. But printer IS giving problems. So I turned it back on. Any other way I could do it? Got hold of Ratscheddar, but it isn't working.

    Also, could you tell me as to why the A: drive is showing up on my PC inspite of me not possessing a floppy drive?
  4. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    I just re-read your first post and i think i missed something :eek:

    You probably have the same problem with Nvcpl as the HP PML service. Neither one allows the service startup type to be changed from msconfig (for reasons i don't know). You could try disabling Nvcpl manually via regedit per my prior instructions but this time look for HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Nvcpl but you'll probably still have the msconfig access denied message cause you need the HP PML service running. (I don't know of any other way around it for now other then ignoring the access denied message)

    As for your strange floppy drive issue:
    > What make/model computer do you have?
    > Install SIW tool
    > Run it and click Hardware->Devices and look for the floppy drive. Select it.
    > Copy/paste all the data that appears into a .txt file and attach it to your next post so i can see the hardware details about it. (you can create a blank text file clicking Start->Programs->Accessories->Notepad)
    > Attach to TechSpot post using the paper clip icon
  5. mukulika

    mukulika TS Rookie Topic Starter Posts: 53

    Thanks a ton. Here's the log.

    Attached Files:

  6. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184


    It would seem you may not have the floppy drive hardware itself but there must be a floppy drive controller (FDC) on your motherboard. That's why you're seeing it. (and the SIW data you showed me indicate Windows has detected and configured an FDC controller and driver successfully)

    Look at the Interfaces listed for your board, note it includes an FDC interface (implying you have an onboard controller)!
  7. mukulika

    mukulika TS Rookie Topic Starter Posts: 53

    Thanks. I'll do that. However, I cannot locate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Nvcpl. It's not there at the location you mentioned. What do I do?
  8. mukulika

    mukulika TS Rookie Topic Starter Posts: 53

    I just ran EasyCleaner and it showed NvCpl to be located at HKEY_LOCAL_MACHINE\Software\Microsoft\CurrentVersion\Run. I opened regedit and had a look at it. It says, DATA: RUNDLL32.EXE C:\Windows\system32\NvCpl.dll, NvStartup. Can something be done with this, that'll take care of the problem?
  9. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Good work! Sounds like NvCpl is a program startup (vs. a Windows service startup). Let's first try to use a tool to control it.. before attempting a registry change.

    Download and install Mike Lin's Startup Control Panel. Then Control Panel->Startup, click on HKLM/Run tab. Do you see the Nvidia program listed there? If so, uncheck it. Then reboot. It shouldn't start up this time. (if you don't see it check other tabs on the tool as well)
  10. mukulika

    mukulika TS Rookie Topic Starter Posts: 53

    Thanks. I did as you told me, but when I opened msconfig and checked, I saw that it's still there listed on startup. I tried going to Control Panel->Startup and then clicked on HKLM/Run tab like I had done previously. Only this time it showed an unchecked NvCpl And another that was checked. When I tried to uncheck it, it said "There is already an enabled/disabled item with the same name. Please rename either the enabled or the disabled item". What do I do now?

    Also, as far as the A: drive is concerned, it never used to show up before. Can you please tell me as to why it is showing up suddenly now?
  11. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Re: Your A drive
    Only thing i can think of is maybe you can enbable/disable the floppy controller in your BIOS settings. Check them. (Had you changed its settings sometime? enabled it without realizing?\

    As to Nvcpl
    I've seen that behavior before with adobe_sl (Adobe Speed Launcher). I'd turn it off but after starting Adobe Reader, Adobe must check, not see it started and would add it back to startups. So i suspect something similiar here.

    Since i don't have Nvcpl on my computer (looks like an Nvidia related thing) best i can do is give you a couple links that might provide you more info. Tho, in worst case, sounds like just a nuisance vs. a real problem
    NVCPL insists on being in startup

    And from, a description of the Nvcpl startup process (just scroll down on the page). Note the first entry is for the legit Nvcpl. The other entries describe malware that tries to hide using the same name.
  12. mukulika

    mukulika TS Rookie Topic Starter Posts: 53

    Thanks a lot. I'll look those up. I suppose it came back on (I had previously disabled it after I used RatsCheddar to bypass the Administrative Rights problem, now RatsCheddar doesn't seem to work anymore) after I updated to the latest driver for my videocard (7600GT).

    But my main concern, really, are the administrative rights. Why do I not have them even though I am the only user and listed as the administrator on my computer? When I open up services.msc and start a service from there, I'm not allowed to turn if off thereafter. That's not supposed to be normal, right?

    Thanks a lot for all the help! :)
  13. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Admin Rights
    If you are logged in on Administrator account you have Admin rights. If a different userid, use Control Panel->Users to see if Admin rights are assigned to the userid

    And, actually, having "admin" rights does not automatically give you rights to everything
    a) Files/folders/registry items are all assigned "rights" by userids and Groups. Those "rights" can be added or taken away. One simple example is looking at folder C:\System Volume Information.
    > By default Sys Vol Info only provides the System rights
    > So if you look at the folder it says "0" size and you won't be able to open the folder unless you add admin rights to it as well

    As far as your services/startups.... Sometimes denied access might be due to viruses changing "rights" but sometimes its just the vendor does it that way themselves for some reason. For your case:
    > I know HPpml service just works that way (i have the same on my computer) and i don't know how to do it different. i think best to live with it and leave it that way
    > As for Nvcpl, the links i provided imply it might be stopped. But are any of these really problems or just nuisances??

    Reporting Startups and Services
    If you want, you can report all your startups and services so i can see (tho still doesn;t mean i can fix/help.. but glad to look if you want)
    For your services
    1) Download Serviwin (very handy tool for viewing and managing Windows Services and Drivers). Run it and click View->Services
    2) Click Start->Programs-Accessories-Notepad to open a blank text file
    3) In Serviwin display, click Ctrl-A to select all the Windows service display rows, Ctrl-C to copy it, Ctrl-V to paste into the notepad txt file and attach to next post using paper clip icon

    For your startups
    Download Autoruns. Click autoruns.exe to run it. Notice its status is displayed in the in lower left corner of window
    • Wait for status in lower left to say Ready.
    • Click File->Save As and save as a .txt file on your desktop. Attach it to your next post using the paper clip icon
  14. mukulika

    mukulika TS Rookie Topic Starter Posts: 53

    Hello LookinAround!

    Sorry for the delay. Read in one of the links that you posted that switching to classic view (NVIDIA Control Panel) will probably disable NvCpl from startup. Will try that and let you know. All this is a nuisance, but I'd really like to have the normal admin rights as the administrator on my computer.

    And here are the two .txt files.

    Thanks a ton for all the help! Cheers! :)
  15. LookinAround

    LookinAround Ex Tech Spotter Posts: 6,491   +184

    Here's an update for now... re: HP PML service causing Access Denied

    1) just happens i bought a new computer. I connected my HP printer, installed the full featured driver (i found on the HP website). I didn;t have the msconfig access denied issue.
    2) I ran HP update. I allowed HP to apply all the updates it found. I still have no msconfig access denied issued.
    3) So MAYBE uninstall the printer driver and reinstall from the HP website might work? dunno, but just passing along the info
    ALSO i found this link Solved: HP PML Driver

    As for other stuff, like Nvcpl you might also try checking your antivirus and antispyware stuff to see if they apply "real-time" control as they might also be the thing that's blocking access

    Hope this might help
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...