1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Asus A7N8X Deluxe + WinXP + SATA problems

By DigitAlex ยท 21 replies
Feb 2, 2004
  1. Hi guys, has been a while since I last posted over here, but now Ive got a new job in a PC shop so have some time.

    Weve got a problem we couldnt solve here.

    A PC with the ASUS A7N8X Deluxe mobo and SATA with XP. 2 HDDs, 2 CD drives. The CD drives are recognized in the BIOS but windows XP does not see anything else than 1 C: drive ...

    We tried all we could think about.

    Thanx for yer help
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    Stupid question, but are those HD's partitioned and/or formatted?
  3. DigitAlex

    DigitAlex TechSpot Paladin Topic Starter Posts: 512

    i said "WITH XP".... yes you were right, VERY stupid question, plz read before posting ;)
  4. NoisySilence

    NoisySilence TS Rookie Posts: 98

    Nforces drivers installed ?
  5. SubKamran

    SubKamran TS Rookie Posts: 166

    Hehe, the jumpers on the drives are configured Master and Slave too? ;)
  6. NoisySilence

    NoisySilence TS Rookie Posts: 98

    SATA does not use the Master/Slave system.

    Check to see if one of the SATA channels isn't disabled in the BIOS.

    The CDROM & DVD not showing in XP could be because of missing proper IDE drivers.
  7. XtR-X

    XtR-X TS Rookie Posts: 829

    Tell us more about how they are connected cable wise.

    Are they all on a primary channel? Split to secondary? What's goin on?
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,452

    Don't you get snotty with me DigitAlex. Your post ONLY says "with XP, 2 HDDs and that it recognizes only C". You would not be the first one to not format the rest.
  9. matris85

    matris85 TS Rookie


    Try to unhide the second one.With Particion Magic for example.
    I think this is the solution (I am proud of me) :approve:
  10. Charles Hammond

    Charles Hammond TS Rookie Posts: 57

    Try setting the jumpers to cable select.
  11. satchmo

    satchmo TS Rookie Posts: 81

    Sata Bios

    The SATA HDD has its own BIOS, so the mobo BIOS would not recognize it.

    When you boot up, do you see a message from the SATA BIOS? You should if everything is working.

    I assume the other HDD is EIDE.
  12. Fug33s

    Fug33s TS Rookie

    Me Too

    I have had the same problem with this motherboard. I have a seagate 200gb sata and a 40 gig IDE hooked up to the mobo. Recently Ive noticed that when I restart I randomly get : DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER. when it tries to read off the sata drive. By the way the sata drive does have xp and the 40 gig is just a backup with files on it. But what really threw me off is I only get this message if the 40 gig IDE drive fails, or I take it out. So basically my sata drive does not get recognized/booted when the IDE drive isnt plugged in. I dont know how to solve the problem.
  13. DonNagual

    DonNagual TechSpot Ambassador Posts: 2,382

    Not sure if this is related or not, but I'll toss it into the pot.

    I can not use the IDE drivers that came with my Asus board. If I do, my IDE devices go wacky. For my DVD drive, I am using the standard windows drivers.
  14. mikeyboy

    mikeyboy TS Rookie

    well heck

    I have the same MB right now with sata dvd burner and sata 250GB drives, and the only way i have ever been able to install WIN xp on it is creating an unattended install with the SATA drivers built into the install. Never had a trouble reading all the drives doing that.
  15. DonNagual

    DonNagual TechSpot Ambassador Posts: 2,382

    I was able to resolve my problem (described in my post above) with this by making sure my antivirus software was off when intalling the drivers. If my antivirus software was on, the chipset drivers would not install properly (specifically the drivers for IDE controllers).

    I don't think this will help with the SATA problems, but post it in case someone else has the same IDE problems I had.
  16. sarbe

    sarbe TS Rookie

    I have the same mobo and have just installed a 200gig maxtor sata2 drive, it recognises when it feels like it, sometimes it locks up, sometimes it comes up with delay write failed, i have used powermax and done full scan and it said it was tickety boo, i am running xp with sp 2, any help would be great. BTW i have set the jumper so the drive runs at sata as that board is not sata2 and i have been assured it is backwards compatible.
  17. khakisheep

    khakisheep TS Rookie

    Solution for this problem is pretty simple. Be sure the jumper located at C216 on your MOBO is set to pins 1 & 2 not 2 & 3. (Diagram should be on page 19 of your MOBO owners manual I believe.) This enables the Raid Controller. After that be sure and install Raid controller drivers from Asus.com. This will take care of your problems and show any SATA HDD's you have connected in XP.
  18. Charles Hammond

    Charles Hammond TS Rookie Posts: 57

    I had just standard IDE drives and my A7N8X motherboard did not like master and slave jumpers. It worked fine with CS (Cable Select). I dont know why that is. But it worked so I did not change it.

    It would not even boot till I cleared the BIOS.
  19. sarbe

    sarbe TS Rookie

    Pin placement was done, It was actually a knackered drive,
  20. jgreg

    jgreg TS Rookie

    i am having a problem when i am traying to install windows xp sp 2, the install donts recognize my hdd (S-ATA 250 gb) can someone tell me what i can do ??
  21. ian the reboot

    ian the reboot TS Rookie

    Ok I do not profess to be an expert but have had experience of building 20 or so different systems over the last 15 years. This however was my first experience of sata drives.Asus mobo WD 250gb Sata WD 80GB IDE Win XP Pro I had a similar problem to yours when upgrading my sons system. After a couple of days where I had xp up and running perfectly on the ide drive and could see the sata drive complete with it's windows directory and other stuff which was readily available just like a second drive, but I could still not get it to boot from the sata drive. The sata drive was being found in the bios as sata 1 and I could set it to be the primary boot drive in the bios but it still would
    not boot. Usually giving me an black screen with no operating system found error. I went back to basics. I found that my son (blame him!) had attached the sata cable to the raid 1 socket on the motherboard and not to the sata connector which is by graphics card slot. So swopped the cable to the correct slot. Still no boot available from the sata drive but this time it halted on a
    black screen with a flashing cursor and nothing else. So swapped the cables again and booted up from the ide xp drive. This immediately found new hardware and installed new drivers. I then used western digitals "data lifeguard tools" which I had downloaded from WD's site cos the sata drive didn't come with an installation disk. I chose the option of transferring the operating system and other files to the new drive (make sure you choose the new drive and not the old 1) and sat back and waited for the transfer to compete. Unfortunately on the ide drive were lots music and video files about 85gb worth so it took about half an hour or so. After the files had been transferred I had to
    reboot. Whilst the computer was switched off I changed the IDE hard disk jumper from master to slave and the ide dvd from slave to Master. Switching back on I went into the bios settings and when I went to the boot sequence lo
    and behold both drives were there but the difference was that the new drive was identified as a SCSI not SATA drive. Changed the boot sequence to the SCSI drive. F10 to save changes and exit and Eureka! boot from the sata drive and off we go. Sata working perfectly and the old ide drive ready for some extra storage if required. I have to add that the original and the new drives were both WD's so if the drives were different manufacturers maybe this would not work. But if you have Maxtors or Seagates or whatever these manufacturers probably have there own drive tools which would do the job.

    A couple of final comments.
    Because most of us probably by OEM package stuff cos it's cheaper than retail packaging we dont get the nice things like cd's or floppys to install drives. On IDE systems this is not a prob as XP handles them quite well, but because
    XP does not come with SATA drivers and motherboard instruction manuals could be a bit better old hands like me find it a bit of a prob.

    The final point is from reading a lot of forums people think that SATA and RAID are somehow linked together and try installing raid drivers when all they really need are the SATA drivers.
    Hope this post helps somebody.
    And remember...If there is light at the end of the tunnel....it's probably a train.
  22. TONS872

    TONS872 TS Rookie


    Ur sata harddisk cannot be viewed from the bios but also the windows cant load the drivers .
    Go to asus website and download the drivers for sata disks.
    Insert the xp cd into the cd rom then let it boot from the cd.
    Press f6 when promted u v 2 b fast.
    Follow the instruction
    that will 100% fix ur problem.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...