1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Asus P5AD2-E mobo and Ultra-X connect 500w psu not powering up

By pantheraleo
Mar 7, 2005
  1. What's up everyone,

    I have an asus p5ad2-e mobo and ultra xconnect psu. When I try to power up nothing happens only a high pitch whine from the psu, no fans no led nothing. I've tried two differ psus and two differ mobos same models and still same prob.
    I've tried to power up outside the case and even tried shorting the on switch to no avail. I've tried to power up with just the video car mem and cpu. Any ideas would be greatly appreciated as right now I have a 1500 dollar paperweight. I'm using intel 3.0g prescott 775 800fsb and geforce 6600gt 265mb ddr pci-e and pqi 1gb ddr2 mem
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Connect the 4-pin square P4-cable from PSU to mobo?
    Voltage of PSU right? 115v USA, 220-240 Europe
    PSU switched on?
    CPU-fan connected to the right mobo-connector?

    PS: checking on the web, those Xconnect powersupplies are a right piece of junk.
    see also: http://www.hardforum.com/showthread.php?t=792566 (Thanks Pizzada)
  3. viperjace

    viperjace TS Rookie

    Blue screens, and then computer not starting!!

    Hey guys, new to the forums. Ive recently had a problem with my computer. I would be playing Guild Wars, or doing w/e (most of the time when GW was up) and a blue screen would show up, saying some kind of memory dump or something. It would restart my computer and then go to windows xp and say windows has recovered from a major error or something. But today it happened, and then it restarted, got to the windows boot screen and just stopped. So i hit power off and now it wont even power on!

    When i try to hit the power on, the LED's inside flash, the fans start for like half a second, and everything just goes dead again. The lights on the NIC work, but it just wont start up now. I had a similar thing happen to me once before with my previous mobo and it just blew something in the circuitry. Was wondering if it was that maybe because it had similar conditions, but it would keep flashing, instead of just once. Any help would be appreciated, thanks!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...