Audigy2 installing as Audigy, control panel functionality limited

By Arris ยท 4 replies
Mar 11, 2003
  1. Ok I got myself an Audigy2 at the weekend and tried getting the coxial digital out to my 5.1 amp which supports 96khz. Was looking forward to some quality sound but found I was only getting stereo left and right through this connection which was weird. Instructions showed that I would have to change a setting to get the proper dolby output but when I went into the creative mediathingy (not quite the proper term but hey its early in the morning here in the UK) I had different icons displayed and they wouldn't launch. After messing around for a while I settled for my amps interpretation of the signal to a pseudo surround and had a game of Splinter Cell.

    Quite enjoyed it, great sound, but was still worried about the soundcard. So I got updates for the software and drivers and installed those thinking that maybe something stupid like the instructions were newer than the driver version/control panel and thats what was causing the problem. It was only at this point that I noticed in the online instruction that the device displays in the creative software as "SB Audigy [C800]" whereas mines displays as "SB Audigy [A001]" and from reading a bit about it seems to suggest that its being detected as the original Audigy core...

    Different driver versions don't seem to make any difference. I tried it in several PCI slots, still not functioning properly. I can't think what else I could be doing wrong/what else I could try. Anyone got any ideas???
  2. yukka

    yukka TechSpot Paladin Posts: 861   +67

    the setting to change the dolby digital decoding to simply output the digital signal for your amp to decode is inside the "device settings" part of the mediasourceGo suite.

    i have had problems with this myself, as i had the creative media player crashing (and the crash was locking the entire pc) so i sent a mail to creative. they told me to uninstall and reinstall making sure that the mediasource was installed to a different folder than the default.

    i uninstalled it but for some reason it was still installed. the volume control was still in the taskbar and the mediaplayer loaded up.

    i reinstalled the software but that completely messed it up, the icons dont point to any applications and i cant access any of the hardware settings apart from the standard ones in the device manager.

    i need a complete reinstall to fix this, depending on your symptoms, you may need the same. mine is a soundblaster audigy 2 platinum and in my hardware settings it displays the card simply as an audigy.
  3. Arris

    Arris TS Evangelist Topic Starter Posts: 4,730   +379

    Thanks for the reply Yukka,
    Just been looking at reviews to see that the code in [] after the name isn't the Audigy version so the [A001] is ok after all. I guess its just the driver/application install thats the problem. I have new Via drivers and a few other bits and pieces so I might just go the hard way and do a complete reinstall. I've read a few posts and articles that mention problems with the applications but when I read that Audigy 1 didn't work with Audigy2 applications I thought that somehow my card might be faulty. I guess I'll give it a go again tonight and see if I can get it working properly...

    So in your complete reinstall did you still install the mediaSource stuff to a different directory?
  4. yukka

    yukka TechSpot Paladin Posts: 861   +67

    i havent got round to the complete reinstall - too much work on atm :(
  5. Arris

    Arris TS Evangelist Topic Starter Posts: 4,730   +379

    Well I've just installed the drivers and not the stupid mediasource applications. I had to set the digital out to pass through to get my 5.1 amp to play DVDs back in full 5.1. From what someone on another forum has told me, to get decoded 5.1 from the Audigy2 I have to use the multichannel in on my amp... Well at least I have it working, and at 96Khz too as my amp supports it :D
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...