Audio device not showing up anywhere

I recently installed a new motherboard (Gigabyte B450M DS3H V2) into my computer (Windows 10 Home, 64 bit) and when plugging my headphones or speakers into the audio jack in the back of the computer, there's no sound. The sound comes from my monitor's speakers because it's plugged in with HDMI. Anything I plug into audio jacks in the back of the computer doesn't show up in any device manager or anywhere else. I did try to update realtek audio drivers 3 times, but even that doesn't show up in the device manager. The only place my headphones show up is in device manager when I "show hidden devices", but even then it says my headphones are not plugged in:
"Currently, this hardware device is not connected to the computer. (Code 45)

To fix this problem, reconnect this hardware device to the computer."
What do I do?
 

Kshipper

Posts: 522   +116
TechSpot Elite
You need to change the audio settings to your internal sound card....Realtek I assume for the back sound holes to work...the HDMI connection has a sound card too so it will work with a TV
 

Kshipper

Posts: 522   +116
TechSpot Elite
The you might have somehow disabled it in BIOS settings?. Hold down the left shift key and click restart (keep holding it down) and you will see the troubleshoot screen. Now you can let go of the shift key. There is a choice in there to Boot to UEFI settings. When you do that you can easily get into BIOS (easier then using the Delete key or F2 at boot).
 
I figured out the problem. I need a fresh install of windows. When I upgraded my mobo, I never reinstalled windows, and windows is still looking for drivers on my old hardware, so I'm going to reinstall and see if that changes anything. Plus, I already enabled audio in the bios.
 

Kshipper

Posts: 522   +116
TechSpot Elite
I figured out the problem. I need a fresh install of windows. When I upgraded my mobo, I never reinstalled windows, and windows is still looking for drivers on my old hardware, so I'm going to reinstall and see if that changes anything. Plus, I already enabled audio in the bios.

Ahhhh yes...that would be the way to go. =)