Battlefield 2142 North Strike

By Cougar125 ยท 7 replies
May 27, 2007
  1. Problem: When trying to join North Strike games/maps I get all the way to the 'Join' button. I click the join button, then get sent back to the Server Listing. This is the message I get
    I have uninstalled/reinstalled a couple of times, gone through all the updates and patches, and still get this message. Does anybody have an idea of what is causing this?

  2. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,485   +45

    Umm, are you using a cracked version of it?
  3. Cougar125

    Cougar125 TS Rookie Topic Starter

    No. I got the game for XMas and I downloaded the Northern Strike patch directly from EA.
  4. Condor

    Condor TS Maniac Posts: 388

    try going here and see if your problem can be solved there

    I got similar problem before but i fixed it by
    1. patch to the most current update
    2. make sure you have 4 gigs of hd space before applying the update

    and there was other suggestions like checking for spywares, virus, allowing firewall access to bf2142 server and a few other i forgot you need to do to fix that modified files error. But check the link and read around see if it help =]
  5. marksman

    marksman TS Rookie

    well i installed northern strike around july i think so anyway i got a month out of it.then none of maps worked at all so i un install and reinstall both of them then the first maps worked and the northern ones even though i have ns unlocks it says i need the game even though i have it!
  6. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    Did you follow the installing/patching order in the thread Condor linked to?
    I had a similar problem when I installed 2142, NS and then patched to 1.4, but it went away when doing 2142, patch 1.4, NS, patch 1.4 again.
  7. mopar man

    mopar man TechSpot Ambassador Posts: 1,379

    Wow, I didn't know you were still around, MrGaribaldi.

    Also, mocking everyone else, make sure you did it in the right order. Many games have troubles if you install patches in the wrong order. Company of Heroes, ftw.
  8. esc420pot@yahoo

    esc420pot@yahoo TS Rookie

    dude i have the same exact problem, got and installed northern strike today, and it seems to have installed, cause im able to do assault line and all the other gamestyles such as "conquest" and "no vehicles" but when i try to join one of the new northern strike maps i get that same problems. telling me to revert to official version or some ****. And iv tried the links above and nothing works. plz help! im axcious to play!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...