Biostar TA880GB+ USB problems, work but not enough juice for external?

By maddmatt02 ยท 8 replies
Dec 10, 2010
Post New Reply
  1. just built a system with this mobo, and the case has 2 usb ports on front that are plugged into a usb header on the mobo, and I have a card reader plugged into another usb header on the mobo as well. this card reader also has one usb port. mobo has 4 usb ports on the back. usb mice and kb, as well as usb network adapter plugged into the mobo, all working. small thumb drives will work in all ports, the hitachi 320GB external wont work in ANY. I tried going through the bios and seeing if I could find something. I also set the jumpers from 5V to 5VSTB figuring it wouldnt change anything and it didnt.

    I had to use this old rockband powered USB hub for the external and now it works fine. the external even came with a usb cord with 2 male ends to give it additional power if one port wasnt enough. I figured maybe somehow one header didnt have enough power, and after both plugged into the case didnt work, I plugged one into the case and one into the card reader and same problem. the drive just makes a sound similar to what a 1.44 floppy sounds like, like it keeps attempting to spin up and then restarts over and over.

    I should note this drive doesnt so this on a HP DV6208 laptop or acer aspire one 533 netbook.

    my sister has this same drive style (250GB though) and had identical problems on her older macbook, but it worked fine on a gateway laptop, my old compaq cq-51 laptop, and their 27" imac...

    is there anything I can try/do to boost the power to the onboard usb ports? seems kind of rediculous that this new setup cant power a external HDD. when this system boots it loads a screen showing voltages after POST, right before windows starts loading and it shows 4.946v for the 5V spot so I dont think the psu is a problem.
  2. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    The iMac is totally different, it has main's power continiously, like a PC does.

    I take it the drive doesn't have a dedicated power source then? What is the problem with running through a powered hub if that works?

    Personally I've always used powered external hard disks, purely because of the power draw from USB.

    Are you using other devices plugged in via USB at the same time?
  3. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    it doesnt have a power source aside from the usb plug. it does have a power jack, but didnt come with a cord. I did just check and the power cord for the usb hub fits it, and works.

    the reason I would like to not use a hub, is because I dont have to on any of our other computers, and dont think I should "have to" with this one. if a 4 year old laptop can power it, why not a brand new desktop?

    and the other items that are plugged in via usb when trying are a logitech wireless mouse/KB, a belkin network adapter, and nothing else.

    also, I dont really know how the usb controllers work, but those are all in the USB ports actually on the mobo. I have tried the front and card reader usb also, which have nothing else in them and the case USB's and card reader usb are on their own usb header on the mobo. I did forget to move on of the plugs to the third header to try that one. but the same jumper that controls 5V/5VSTB for the 2nd header controls the 3rd header so I imagine its the same controller as well, but I really dont know for sure. so I will try that.

    the way I had to do it now with the hub just looks crappy sitting next to this brand new system. I could get a better looking hub that has a usb cord longer than 6 inches and it would help out with the "professional" looks I guess... lol

    *edit - tried the other header and also disabled/unplugged the network adapter and the mouse/KB receiver and it still didnt work
  4. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    You don't "have to", but if you want help expect to hear suggestions to "help" you.
  5. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    Im not trying to sound rude or anything, and I do want help.

    I was just saying that it works on 5 computers that I know of, only 2 that dont, this ne and an old macbook. and back when I searched about it on her macbook it was something that couldnt be fixed (from what I read).

    but her macbook is OLD... lol, and every computer newer than hers I have tried it on, it has worked on

    so I was just figuring there must be something to do to get mine working. even if I do later decide to use a powered hub, I would like to figure out why it doesnt work.
  6. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    The reason it probably doesn't work is due to lack of power. A USB port can only supply 500mA, its not uncommon for higher drain USB devices to need double that in order to work - Which is why they some times come with 2 USB connectors (use two and you got 1000mA, which is enough for pretty much everything.

    Have you tried connecting it to the main USB ports at the back of the computer? The ones built into the motherboard design, rather than the ones connected to headers.
  7. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    it's usb cord does actually have 2 identical male ends, and if I remember right, it is to draw extra power if needed. But on none of the other computers is even that needed. It works with just one end plugged in. And yes I have tried the ones on the mobo itself, even tried plugging both ends in back there. Same problem. I think I am just gonna get a black usb hub and mount it to the desk under the monitor shelf for her (built this for my fiance).
  8. Leeky

    Leeky TS Evangelist Posts: 3,797   +117

    So it doesn't work even with both connectors fitted in motherboard connnected USB ports?

    If you go and get a USB hub you need a powered one with at least two dedicated 1000mA ports, which will enable you to double the current power output to 2000mA should you need it.

    If that won't run it, there clearly is a problem somewhere with your hardware.

    Silly question, but your certain your USB ports are working right?
  9. maddmatt02

    maddmatt02 TS Rookie Topic Starter Posts: 88

    correct, it won't work with both plugged into the motherboard, or any ports for that matter. And yeah I know the usb ports work, I have my network adapter and kb receicer in the ones on the back, I have successfully used 2GB flash drive on all ports in the front, and the hard drive works in the usb hub I have through the front ports. Almost makes it sound like a problem with my external but it works just fine with the hub on this computer(and only one end plugged into the hub) and works fine on our other two with only one end plugged in...

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...