Boot hangs on Processor ID... BIOS problem?

By indus49 ยท 4 replies
Nov 8, 2006
  1. Lately, when I start up my PC... the system hangs on the 'processor id' portion of POST. It will continue within a minute or two, test RAM and then finish the boot process.

    Nothing has changed with the configuration of my system recently... so my thoughts go to problems/imminent failure with some kind of component. Any ideas? Thanks!
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Try resetting the bios... Things like quick boot and show splash screen
  3. indus49

    indus49 TS Rookie Topic Starter

    Tried that, I also tried booting without one ram stick, then without the other... also tried removing the HD... no difference. Still takes 30-60 seconds to get past the processor id and start the mem test.
  4. AtK SpAdE

    AtK SpAdE TechSpot Chancellor Posts: 1,495

    Did you check BIOS for the options listed like Quick Boot, etc? I have seen a BIOS battery die and it continuously sets the settings back to stock. Weird, but I have seen it.
  5. indus49

    indus49 TS Rookie Topic Starter

    Follow up

    I started pulling everything out... when I yanked all my PCI cards, the startup hang disappeared. I reinstalled the cars slightly out of order, and it seems all is well... perhaps an IRQ problem, or some rogue dust?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...