BootMGR missing/corrupt, bootrec.exe useless

By ChrisIVX
Nov 1, 2010
Post New Reply
  1. Hi there I'm back, after only a few months of computer bliss.

    I run a 2 hard drive Windows 7 installation with the OS and program files on a fast SATA drive and general storage on a larger IDE drive.

    A week ago my computer failed to turn on past post, telling me first "No disk detected!" and then that the BOOTMGR was missing. After going into the BIOS and changing "Halt on error" to "never", it then said the BOOTMGR is corrupted.

    When I put the windows DVD in the drive and booted from that I got a lot of error messages telling me e.g. "C:/PSP is currupted" and I think advice to run chkdsk. Interestingly my PSP directory should be on the D:/ drive. Startup repair found no errors. I did some research and tried bootrec and all options (fixboot, fixmbr, rebuildbcd) which didn't work until I did more research which told me to use Diskpart so make sure the right partition/disk was active. I also ran a chkdsk /r at one point around here. After all of that, I could get into Windows and access both drives.

    Every single day since then I've had something go wrong, either a message saying something (usually the recycle bin) is corrupted or the D:/ drive (not the windows drive) being inaccessible, which chkdsk /r always fixed.

    EDIT: Towards the end of the week the PC would seemingly freeze on the "starting Windows" splash screen.

    I got quite concerned about all this, so yesterday backed up and clean installed Windows on the C:/ (sata) drive, where it was before.

    Now I get the "BOOTMGR is missing" message but the above methods used to fix it last time have not worked at all. Somehow the Windows DVD allows me to boot into windows after a startup repair and restart, but every time I need to do this, and the D:/ drive does not show at all (apart from in disk manager, but all my stuff is stored/backed up on there and so I mustn't reformat it).

    The most recent development is that I manually booted (F8 on POST) using the IDE drive and got into windows, but this is the wrong drive, and still I can't see that same drive in My Computer.

    This is posted in the Windows section but I'm not sure if it might be a hardware thing, since both drives seem to be affected. Maybe even a motherboard thing? (MB was recently RMA-ed for not starting up properly; I can't find the thread). Can anyone please advise me on how to fix my BOOTMGR?



    A few new tidbits:
    - My motherboard just froze during the post, before going into setup. Maybe that has to do with it.
    - After changing the boot priority of the hard disks in setup I see Windows boots fine. I think this means the bootmgr is on the wrong hard drive??
    - My secondary drive wasn't showing up in Windows because it wasn't assigned a drive letter. However now it's showing up as completely empty! Can anybody please name a good free un-deleting program? I tried NTFS Undelete and it fond nothing.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...