BSOD 0xD1 stop error

By MickFin
May 29, 2010
  1. Hi guys,

    I've been getting a bsod systematically on startup for about a week on my laptop: receive the stop error 0xD1 DRIVER_IRQL_NOT_LESS_OR_EQUAL

    I'm not sure what info could be helpful for figuring this one out so here's all i can think of:
    The computer, a rather ancient HP Compaq nc8000 running:
    XP Professional,
    Intel Pentium M 1600HZ,
    ATI Radeon Mobility 9600 series,
    512 RAM - can't find the make

    I haven't added any hardware recently.

    I would have tried wiping it but it's got some files on I need, and I can't get them off - receive I/O errors when trying to copy to a USB drive, FTPing to my web host won't work, can't send email attachments, and up until today the CD drive wasn't working.
    I have ran a chkdsk, a defrag, have restored the system several times to a previous date, have tried Last Known Good Configuration to no avail.
    I managed to download a Microsoft Automated Troubleshooting Services fix for that and lo' and behold it worked (at least it's reading, I havn't tried writing) so I managed to load the HP Driver Recovery CD. That appeared to install all but one driver okay (printer driver failed) but didn't make the BSODs go away.
    I have seen on other threads that the problem may be faulty RAM, unfortunately because of the above problems I can't run memtest, although I've never had any RAM problems before and havn't added any recently.
    I have tried running a few antivirus/spyware scans:- AVG, Malwarebytes, Spybot S&D, the latter found a couple of trojans in the registry, one malware entry and some cookies. Cleaned them but that didn't fix it.

    I should mention in case it's of any signicance that Safe Mode doesn't load properly, it runs up until Windows\System32\Drivers\agp440.sys and then hangs, then the message "Press ESC to cancel loading SPTD.sys" flashes momentarily at the bottom of the screen. I can load Safe Mode if I tap esc at that point.

    Previous to these errors the laptop was running more or less fine - a few problems with the screen flickering to black (or very dark) when I tilted the screen back or forth - always returning to normal when I rebooted. I figured that it was a loose connection due to it being quite an old machine. It was a second hand and sound never worked on it since I've had it, I assumed this was due to missing hardware but I never looked into it as it didn't bother me. It does bleep when I get alert boxes but that's it.

    I have also tried dusting the outside vents but I'm reluctant to venture inside the machine as I'm a bit of a greenhorn and don't want to make things any worse.

    I would try to repair using the Windows Install CDs but I don't have them at hand. I know a replacement is probably overdue but I can't afford to replace it right now. Any help you could give would be a real help to me, thanks for taking your time on this one.

    Ps. I have attached my 5 latest minidumps and a hijackthis log as was recommend in some other posts. I hope I have provided them in the correct formats. Once again, thanks for any help.

    Attached Files:

  2. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    I have the same cpu and the ATI 9000 graphics in my ancient Toshiba Tecra S1. I even had 512 megs of RAM but upgraded to two gigs of PC2100. Like you, I wish I could buy a new one but can't at the moment.

    Anyway all five error dumps are 0xD1 and these are usually caused by faulty drivers but also by mismatched or faulty memory.

    The problem is all five simply cite Unknown_Module (ANALYSIS INCONCLUSIVE).

    For clarification, are you saying the DVD drive doesn't work at all? All Memtest needs is a few seconds after boot-up to engage. This is what I would recommend to do next.

    I also understand the problems associated with an old laptop. Even with updating the RAM, new harddrive, disabling the a/b and going with a PCMIA Belkin MIMO G card, the system still freezes especially when trying to connect wirelessly.

    And it takes time to load any and all drivers.
  3. MickFin

    MickFin TS Rookie Topic Starter

    Thank you very much for your help with this, it was greatly appreciated.

    With regards to running memtest, I couldn't do this at first because i didn't know the boot menu password. So i had to open up the machine to detach the lithium cell and let the bios reset. Once that was sorted, I ran memtest for about 30 passes, and it didn't throw an error.

    In the end i managed to retrieve all the files i needed, and since Memtest indicated there wasn't a hardware issue with my RAM, i guessed the fault was a software one. So i decided to wipe XP and install Ubuntu. This worked i am happy to say, and so far all is well. Although now i have the task of learning Linux.

    Once again, i must say i am very grateful for your time and help.

    All the best
  4. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Thanks for getting back to us and how you resolved it. If you need help on Ubuntu there is a forum here dedicated to Linux OSs.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...