Drivers [BSOD]Hitman: Blood Money - "cmuda.sys"

Status
Not open for further replies.

MTiN

TS Rookie
Hey there!
I've just got that new game, Hitman Blood Money which is really cool, BUT:
every time in the third mission when I get past a specific mission Objective, it crashes to a Bluescreen! This error doesn't happen at the exact same place all the time, but always after I've done a specific thing and then somewhere on the way back...booom....
because it didn't display the error after the crash (screen was just plain blue) I've used that "WinDBG" from the Windows debugging tools and opened the minidump to find the cause...seems to be my c-media driver (it says "cmuda.sys" is the cause, so...)

Now what can I do? Already deactivated EAX in Hitman, but that didn't help...
here is a screenshot from the configuration utility of my onboard sound, I really hope somebody can help me because this game rocks!

oh and sorry for my bad english :(
 

Attachments

Rik

Banned
Have you tried running dxdiag to see if that finds the problem?

Just in case, heres how.

Click start button then select run, type dxdiag.
Run through all the tests and check the results.
 

MTiN

TS Rookie
dxdiag doesn't show any errors!
and I can't find any updates, as you can see on the shot my chip is a "CMI9780", but even on the ofiicial cmedia website there aren't any new drivers for that?
 

GuildwarsGirl

TS Rookie
it won't come up in the dxdiag. I'mhaving this problem with guildwars. The Cmuda.sys causes your computer to blue screen. It's an audio driver thingy. it's from C-media, as far as I can find you need to download the latest friver to fix it.
 

wolfram

TechSpot Paladin
Download them from HERE and see if that solves the problem.

PD: Make sure you have any popup blocker disabled before trying to download the driver.
 

detonator1968

TS Rookie
OMG, I've been posting about random reboots, but it mainly happens on Hitman, on the 3rd Mission when I get to the end and the plane flys away the pc reboots. If I try again it will reboot half way through.
 

detonator1968

TS Rookie
Talked to Eidos yesterday, seems my drivers weren't as upto date as I thought, also they released a 1.2 patch a couple of days ago all of which enabled me to get past the 3rd level
 

MTiN

TS Rookie
hey...it's me again!
that driver you postet is indeed working better then the default one I got with my pc, but i stell get about one bsod in every level of the game or something like that...but thats fine with me

but...now I've got MicroMachines V4 and it has the same Problem...can launch the programme and everything fine, but as soon as I load a race I see about 1 till 3 seconds ingame graphics and then it crashes...with the same cmuda.sys error...this is really driving me nuts, since there aren't any other drivers on the net for my onboard chip :(
Already tried everything like enablin/disabling "Xear3D" and set the Speakers to Headphones instead of my 5.1 system, but nothing helps...

what could I do?
maybe there is some kind of generic AC97 driver? I mean, I don't really need the 5.1 sound, if I could just play these new games fine...

Edit: attached a Minidump, maybe you can do anything with that(rename to .dmp)...
 

korrupt

TS Rookie
Is it a legal or illegal copy? If it is illegal - there may be nothing you can do about + techspot does not condone any illegal activities.

Regards,

Korrupt
 

wolfram

TechSpot Paladin
MTiN said:
hey...it's me again!
that driver you postet is indeed working better then the default one I got with my pc, but i stell get about one bsod in every level of the game or something like that...but thats fine with me

but...now I've got MicroMachines V4 and it has the same Problem...can launch the programme and everything fine, but as soon as I load a race I see about 1 till 3 seconds ingame graphics and then it crashes...with the same cmuda.sys error...this is really driving me nuts, since there aren't any other drivers on the net for my onboard chip :(
Already tried everything like enablin/disabling "Xear3D" and set the Speakers to Headphones instead of my 5.1 system, but nothing helps...

what could I do?
maybe there is some kind of generic AC97 driver? I mean, I don't really need the 5.1 sound, if I could just play these new games fine...

Edit: attached a Minidump, maybe you can do anything with that(rename to .dmp)...
That minidump is incorrect. I tried to read it and got just garbage characters.
Just a suggestion. Remove anything related with realtek, and start the game without sound. Check if the BSOD appears.

Good luck, and please attach a working minidump :)
 

MTiN

TS Rookie
@korrupt why do you think that I'm using an illegal version?
really loved the old micromachines and rushed into the store as soon as it was availible here in germany :D

oh and I'm now trying that without sound, but why should I disable everything related with Realtek? I mean, my ethernet card shoudln't effect the game, right?
anyway, here are the three last tries to get it to run (with sound enabled) from C:\Windows\Minidump....I hope you can read them now!
 

wolfram

TechSpot Paladin
MTiN said:
oh and I'm now trying that without sound, but why should I disable everything related with Realtek? I mean, my ethernet card shoudln't effect the game, right?
anyway, here are the three last tries to get it to run (with sound enabled) from C:\Windows\Minidump....I hope you can read them now!
I´m sorry, I didn't mean the ethernet, just the audio.
 

MTiN

TS Rookie
thanks!
just tried to disable the audio device in the device manager (or however its called in the english winxp) as you can see here:

but when I run MM4 now it just displays the first loading screen for a second and then immideatly exits back to the desktop...seems like it requires some audio device...
 

wolfram

TechSpot Paladin
You don't need to disable it, uninstall the sound driver from the Add or Remove programs in Control Panel.

I'm damn sorry, I couldn't read properly the minidump. I'm just too ***** to do that :dead: :confused: :unch: :mad: . I'm sure someone WAY smarter than me like howard_hopkinso will do the job for you.

Also, take a look HERE. I hope that can help.
 
Status
Not open for further replies.