BSODs on W7, driver_irql_not_less_or_equal (netr70.sys)

By Gwydi0n ยท 4 replies
Jan 31, 2011
Post New Reply
  1. Hi there, long time reader first time poster.

    A while ago I started having problems with my computer.
    At certain times I get the following bluescreen:


    STOP: 0x000000D1

    - Address 9022977F, base at 90202000, Datestamp 45923fd3

    I have found 3 main reasons that trigger this BSOD:

    - Playing any type of streaming audio/video (like listen to music/watch anime series/...)
    - Download more then 2 things at the same time
    - Startup WoW when it is NOT minimized. (when I minimize it while it is on the loading screen, it starts up)

    It also happend on numerous other occasions, but these are the moments it crashes 90% of the time. It also only occurs when I am connected to the internet!!

    When pressing the "find solution for problems" button after I reboot it says I have a problem with a Ralink Technology product and that I need to update the driver. So I updated the driver for my Raeltek RTL8168C(P) (I guess this is my onboard networkcard?) and rebooted.

    This did not solve anything. So i disabled the Raeltek adapter in my device manager. This didn't change anything either

    I then dusted of my pc, defragged everything, put my RAM in different slots, started up with only 1/2 of my RAM inside, ... none of this worked.

    Finaly out of misery I decided "well f*ck it, I'll just format". After formatting it went well for a while, I was able to watch clips online and stuff untill it all of a sudden came back (after a day or 3).

    Please help me!!
    My knowledge of computers is not great enough to fix this problem on my own!!

    Below are my specs, minidumps and a HiJack this log.


    MSI k8n Neo 4 Motherbord
    Intel(R)Core(TM)2 Quad CPU Q9300 @2,5Ghz (not overclocked)
    Nvidea Geoforce GTX 260
    4GB RAM Corsair

    !! I am connecting to the internet using an old Belkin Wireless G USB adapter: Belkin F5D7050 !!
    Normaly I connect with a Linksys Wireless-N PCI adapter model WMP300N, but the antenna on that one broke. I also had the problem while using that adapter

    PS: I accidently made a post in the Windows section of the forums first, that can be removed.

    Attached Files:

  2. Gwydi0n

    Gwydi0n TS Rookie Topic Starter

    adding a dump file from a crash that was a result from downloading. The other 5 crashes in the first posts were from bsods's from streaming video's online.

    Attached Files:

  3. Route44

    Route44 TechSpot Ambassador Posts: 11,984   +72

    Every one of your files are the 0xD1 error and these are usually caused by faulty drivers.

    In every files they cite the same netr70.sys as the cause of your system crashes. This is a Ralink 802.11 Wireless Adapter Driver.

    Did you build this system or purchase it such as Dell, HP. etc.?
  4. Gwydi0n

    Gwydi0n TS Rookie Topic Starter

    I build this system myself, I think I have it for 3 - 3 and a half years now.
    All parts were purchased seperatly, but at the same store and it has been running flawlessly all this time.

    The strange thing is that I have never before encountered any of these issue's. They just started randomly appearing all of a sudden.

    Before my format I was using a cracked version of Windows 7, that I was not updating in any way. When the BSOD's started to happen, I tried fixing them in the way described above, when that didn't work I formatted, installed the driver that problem solving suggested I'ld instal and crossed my fingers.

    This did not solve the problem either.

    I have been looking arround online and have been finding some very contradicive answers to my problem. Some sites say it's an issue with the driver of the Raeltek device. Others blame it on the Belkin wirless G adapter and say I have to download the XP version of that one and install it in compatibility mode.

    And even other sites insist it is a virus that in some way cloacks itself as a malfunctioning driver...

    Just to be on the safe side I have ran 4 Memtest+ scans, none of wich encountered an error. So a RAM failure is out of the picturs (still running more scans atm)
  5. Gwydi0n

    Gwydi0n TS Rookie Topic Starter

    Ran 9 Memtest+ scans, not a single error
    also did 4 system stresstest, none of wich gave any problems.

    I am confident now that the issue is situated only with my internet adapters. I have no UTP cable available to me at the time, but will try to see if the issue is solved when connecting directly to the router.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...