Cannot delete Registry key Windows Vista

By Andreobrecht ยท 4 replies
Feb 27, 2007
  1. Hi,
    Running a business edition of Vista, I need to remove a Vid_Pid in the Usb folder in order to re-enumerate a device but somehow it does not let me, invariably returning an error message "error deleting Vidxxxx".
    I am doing this from an admin account and UAC has already prompted me to elevate my rights.
    I also have tried running Regedit from an elevated prompt but it made no difference.
    I have tried deleting other Vids to no avail.
    Thank you for your time.
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    That doesn't sound really safe. Maybe you should delete the device from Device Manager, after enabling "show hidden devices" ?

    But if you want to modify the registry directly, check that you have permissions for that particular key (right-click the key).
  3. Andreobrecht

    Andreobrecht TS Rookie Topic Starter

    Thank you for your answer.
    I already have set the Permissions to allow full control at the usb folder level and cascaded to all child objects.
    It is perfectly safe to remove the device this way.
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I understand Windows Vista accounts are more unix-like in that the administrator accounts have limited access to system-level functions.

    When you 'elevate' your rights, is this the equivalent to logging in as a system administrator... aka. 'root' or 'superuser'?

    If not, is there some way to give your account complete system privileges?
  5. Andreobrecht

    Andreobrecht TS Rookie Topic Starter

    Hi Rick,
    I think you might have nailed it there.Admin is not strictly speaking "root" so I think the workaround will be to switch off UAC.The machine with the problem is in our Manila office so I'll contact them later as they work nights.I'm getting a Buisness Edition before the end of this week so I will be able to test it myself.
    Thanks for putting me on the right track.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...