Build a PC Cannot install operating system at all


TS Rookie
I just put together a new system and cannot install any operating system onto it. I've tried Windows 7 x64 and x32 as well as Ubuntu 11.04 x64. They all stall out the same way (pictured below). For Windows, it stalls out just after resizing the screen to fit the optimum monitor resolution. For Ubuntu, it stalls out on the first dot after going through the dots under the logo twice. I'm trying to install the operating system from a flash drive in both cases. As this occurs with both OSes, I'm of the opinion that there's something wrong with the hardware, but what? (I'm currently on an Asus Eee, so burning a disk would be difficult at best) I've tried resetting CMOS and taking everything apart and putting it back together again and googling the problem, leaving the system on for 15 minutes in that state.

System configuration:
Motherboard: GA-M68MT-S2P rev 3.0 with onboard graphics (NVidia GeForce 7025/NVidia NForce 630a)
Processor: AMD Phenom II x6 1090T black box
RAM: Kinsington KVR1333D3N9/2G x2
Harddrive: Seagate 1TB LP Serial ATA HD 5900/32MB/SATA-3G

The only difference between Windows and Ubuntu is the color of the screen. Below is Ubuntu. Windows is blue when it does this, but otherwise looks the same.
Edit: Ah, I cannot post a picture. It is diagonal lines that go from the lower right corner to the upper left. They are composed of short lines with white and black pixels on either with some white lines intermixed.